• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Build not powering on after CPU cooler change

Jun 11, 2020
1
0
10
0
Hey guys, so I’m having some issues with my build not powering up, but I’ll give you a little background to understand my situation a little better. For the record I’m a pretty handy person, used to working on cars and doing most of my own repairs in the home, so I don’t think I screwed things up by being an idiot because I’m usually very cautious (but I guess anything is possible)

I built my first PC about a month ago and the first try was a headache. Got everything in and PC would cycle on and off at first, but then wouldn’t power up at all. After a day or so of trying everything I could I had a friend of mine who has built several PC’s come over and try to diagnose the issue, we tried everything again, reseat alllll connections (reseat RAM, reseat GPU, all power connections etc..) and still it was a no go. So I decided to return my RAM, PSU, and Mobo and get a new combo.
Got all my replacement parts in, put it all together, installed windows and everything was up and running and working fine.

After gaming on it and enjoying it this last month, I noticed my CPU was running a lil warmer than ideal, so I wanted to upgrade from my stock AMD Wraith cooler to a Noctua system. So yesterday I went to replace the cooler and got all my parts back in and now I’m having the exact same issue as before. No power, no spinning fans, nothing happening. My PSU is a modular gold rated EVGA which has an indicator light on it to show it is receiving power when connected to outlet, this light is green, so PSU seems to be working fine. All cables connected to PSU are well seated, and cables connected to Mobo are also. RAM has been taken out and reseated, GPU has been removed and reseated, CPU has been removed and all pins are in perfect condition, no weird smells or signs of shorting, everything looks great but I’m still getting NO POWER.

Hopefully all this makes sense and hopefully I can find some answers because this is driving me absolutely crazy. I’ll put all my parts below for reference.

CASE: NZXT H510

MOBO: MSI b450 Tomahawk Max

PSU: EVGA 650w G5

CPU: Ryzen 5 3600

GPU: Sapphire RX480 Nitro 8gb (pre owned) (replaced with 1660 super, still no power)

RAM: Corsair Vengence 8gb (x2)

EDIT: Well it looks like PSU is working fine, it came with a tester to clip onto the 24 pin so you can plug it in and switch it on to see if the fan spins. Fan is spinning in PSU, so I assume it’s not the issue here. Tried booting up with 1 stick of RAM, no go. Also, I’m doing all this testing outside of my case, trying to get it to post on my Mobo box. GPU was also replaced and I’m still getting nothing, is this a Mobo issue? Seems crazy to have a fresh Mobo go bad, so quickly, and on top of that having two Mobos go bad in two months. I don’t notice any blown capacitors, or any burnt fried spots. I haven’t had any static while I was working on everything. Am I doing something wrong?
 
You do have the cooler plugged into the CPU_FAN header correct? Ther emust be a fan plugged into that header for the system to power on, otherwise it thinks there is no cooler installed and wont boot to protect the CPU.

If you do the next thing I woudl recommend is that you take off the cooler, remove the CPU and inspect both the CPU pins and mobo socket for any damage.
 

ASK THE COMMUNITY