Question Computer disables powerline adapter connections ?

May 8, 2022
So I’ve made a previous post on this issue but I’ve since gained some information. My new computer disables my powerline adapter connection. I have tried 2 powerline adapters (Netgear AV5001 and Extollo Lansocket 1500) so I am almost positive it is the fault of the computer. This issue is specific to this computer, and I have tried two unique desktops under the same wall and same exact connection using the same powerline and they work fine and therefor I know its also not the wall.

This issue only began when I switched out to a new PC. The powerline shows a healthy connection (A middle green light) for the powerline to powerline connection until I plug in the computer where it turns red. All other lights are fine. The powerlines connect correctly without the computer, so I have no idea how plugging it in stops the boxes from speaking to eachother. If I do have internet, the connection is EXTREMELY weak (around 1Mbps download). I have been working on this issue for days so any help is extremely appreciated.


Ryzen 5500G
Asus ROG Strix B550
Gigabyte SFX 650 PSU
16 GB Corsair Vengeance

I have tried:

  • resetting windows completely
  • tried multiple hard drives
  • tried every speed duplex setting
  • installed and tried many drivers
  • resetting the powerlines to factory default
  • changing to optimal DNS
  • switching out motherboard, ram, and gpu

I’m getting desperate at this point lol.


Make and model information for modem, router, or modem/router if combined.

How many other network devices are on the network: wired and wireless?

Any other network devices: switches, Access Points, Repeaters, etc.?

Run "ipconfig /all" (without quotes) via the Command Prompt. Post the results.

The router's logs, if available and enabled) may provide some clue. Who has full admin rights to the router? You will need help from that person.