Question Computer won't start while monitor is plugged into GPU

Apr 6, 2020
2
0
10
0
Recently I have been having an issue with my computer, where it won't start if I have a DisplayPort or HDMI cable connected from my monitor to my GPU. If I press the power button while these are connected, my fans will spin for about half a second, then nothing happens.

However, if I disconnect the DisplayPort cable, my computer starts and I can plug in the DisplayPort cable following startup and it works fine.

Prior to the start-up issue, I had issues with my computer randomly black-screening during use which could only be resolved by hard-resetting the computer. I noticed that, while there was no video output, my computer functioned normally during these outages (I could still talk in Discord calls).

I have tried using my GPU in a friends system, and he had no issues with start up, or any crashing. So I'm wondering if this is likely a case of a dying power supply, or if there is another factor?

Thanks in advance for your help!

System Specs

Motherboard: Asus Z-97 Pro-Gamer
Graphics Card: MSI GTX 1070
CPU: Intel i7-4790k
PSU: Corsair CX600M
RAM: HYPERX Fury (2x8GB)
Storage: 2 x 250 GB SSD (1 Samsung 860 Evo, 1 Crucial MX500) & 1 TB HDD
 

MadsModsat

Prominent
Oct 10, 2019
790
150
640
41
The symptoms you describe are often seen when the PSU is of poor quality, failing or not powerful enoough:

It would be easier to give advice if you could post the complete specs of your PC, including make and model of the PSU, and possibly its age?
 
Apr 6, 2020
2
0
10
0
The symptoms you describe are often seen when the PSU is of poor quality, failing or not powerful enoough:

It would be easier to give advice if you could post the complete specs of your PC, including make and model of the PSU, and possibly its age?
Thanks for your reply. Here are my specs. I built my computer in the summer of 2016, and I haven't replaced any components since then (other than adding additional storage).


System Specs
Motherboard: Asus Z-97 Pro-Gamer
Graphics Card: MSI GTX 1070
CPU: Intel i7-4790k
PSU: Corsair CX600M
RAM: HYPERX Fury (2x8GB)
Storage: 2 x 250 GB SSD (1 Samsung 860 Evo, 1 Crucial MX500) & 1 TB HDD
 

ASK THE COMMUNITY

TRENDING THREADS