[SOLVED] Computer Worked for a year now i need help

Dec 3, 2019
2
0
10
0
Computer worked fine for a year, Shut it down one night and started it up the next day 20 minutes later it shut down the power button did nothing at this point. Clearing the Cmos by removing the battery was the only thing that brought it back to life ... for 20 minutes, i figured the psu was going bad so i swapped the power supply. Alive it booted fine and i played Rocket League and No Mans Sky for 4-5 hours I left the computer running overnight for a download i woke up the next day and everything was fine download still goin so i went about my day.
I came back to it about 24 hrs after its initial boot and it was dead with no response from the power button. Now the only thing that will get it to boot is to leave it unplugged for a few hours but it only stays on for a about 20 minutes then the problems start again. i have re seated everything and every plug i have took the hole thing apart and put it back together checked every cord...
im not new to this but im not an expert either i am at a loss,
Please help system is as follows
Mobo - MSI Z270 SLI
Cpu - Intel Core I5 7500
Ram - GSkill Trident Z 2x 8gb 3000mhz
Gpu - XFX Radion 7870 2gb Gddr5
Psu - (Old) Corsair CX 550W
(New) Corsair CX 750w New
OS - Windows 7 Because my games wont run on XP
 

Lutfij

Titan
Moderator
You should be on Windows 10 for that platform. That being said, breadboard the system with only the bare minimum, no discrete GPU. See if you're able to get into BIOS. Once there, check and see which BIOS version you're currently on. If you have updates pending, gradually work your way to the latest there is.
 

Lutfij

Titan
Moderator
You should be on Windows 10 for that platform. That being said, breadboard the system with only the bare minimum, no discrete GPU. See if you're able to get into BIOS. Once there, check and see which BIOS version you're currently on. If you have updates pending, gradually work your way to the latest there is.
 
Dec 3, 2019
2
0
10
0
Hello sir Luthj first of all i would like to say Thank You From the bottom of my heart you made my year i was so frustrated with this and i didnt evin think of a bios update so yes im on day 2 now with no problems so far and it seems to be working fine.
Secondly i would like to say i know i should be on windows 10 with this platfrorm but i honastly just cant do windows 10 it litterally took me 45 minutes the first time using it to find my computer .... i couldnt find it becouse it wasnt my computer anymore....... and i took that to heart,
Honastly im just waiting on the steam proton thing to smooth out and for windows 7 to be phased out before switching to linux fully.
I sencearly thank you my good man for you wisdom is far more boundless then mine i appreacate you to no end .
also if you could give your thoughts on how the bios could fail like that i would be all ears thx again Luthj
 

ASK THE COMMUNITY

TRENDING THREADS