Core i7 920 broken memory controller??!?!?!?!

cmldexter

Distinguished
Jan 28, 2010
19
0
18,510
I had 12gb installed on my i7 build, one day it decided to say 8gb :eek: :eek: :eek:
I did all the troubleshooting possible and the most I get was 10gb when I had 12gb on!! Both the BIOS and the OS said 10gb. First I thought it was the mobo, then I test every memory individually in every memory slot and they all work. I contact ASUS and they told me to do CPUZ (dumb me, I thought that the BIOS said everything...) and I saw the 12gb, 2gb in every slot. In the end, I contacted Intel to get a replacement and just sent in my 920 today. Have this happened to anyone???
 
I actually have heard of this before, several times. I do not have a 920 so I don't know a ton about it, but in some cases raising the voltage to the memory controller helped (in others it didn't though, so your problem may very well have been a defective component).
 

cmldexter

Distinguished
Jan 28, 2010
19
0
18,510


Dunno if the guys at ASUS wanted to avoid the hassle of the mobo (still covered by the warranty for another year), but from the testing I did I was pretty convinced that it was the processor. CPU-Z read 12gb where both the BIOS and OS said 10gb. I tested every channel indivudually so it coldnt be the mobo. Plus, the mobo does not have its own memory controller, the CPU is now in charge of that.
 
Check do see did a memory limit get manually set, and un-set it: Click the Start orb, and type in msconfig. Right click the msconfig app to run it as Administrator. That brings up the configuration utility. Click the Boot tab, and then click the Advanced Options button. In that window, there is a setting for Maximum Memory - Make sure the checkbox for it is clear (not checked), then reboot your computer.
 

cmldexter

Distinguished
Jan 28, 2010
19
0
18,510


Too late.. :( i've already contacted intel and sent in my 920 to get a replacement one...

It is weird because the bios also says 10gb :??: :??: :??:
 

fi-account

Distinguished
Feb 5, 2010
4
0
18,510


Inform us what happens when you get back your i7. Am experiencing a similar issue, just got my board back from an RMA and the store/their supplier said that there's no problem with it. Hopefully it's just the memory controller in my i7 that's fried.
 

cmldexter

Distinguished
Jan 28, 2010
19
0
18,510


You my friend are lucky! because i just got from the mail my new core i7 replaced by the warranty. LOL i had C0 stepping and now they sent me the newer D0 stepping models
S-SPEC: SLBEJ yay!!!!!!!!
I will inform u shortly on how this turned out
 

fi-account

Distinguished
Feb 5, 2010
4
0
18,510


Well I just got back from the processor store and my i7 is working fine >.<. Bought a new Corsair Dominator kit still the same >.<. Am gonna go straight to the other store's supplier next week to inquire how they tested my board