Question CPU red light blinks once, PC doesn’t boot

Dec 26, 2021
2
0
10
0
Intro
Hello, as of making this post I am absolutely clueless on what to do, my brother (since he has far more knowledge about building PCs) built this PC about a year ago, everything went fine and was working until one point and now the pc doesnt even boot past the motherboard logo..
I’ve looked into hundreds of threads and it feels like I’ve flown all over the internet with this. To say first of all I am no pro in building pcs so take it easy on me haha.
The problem itself
So, I start the PC, everything seems to be working correctly until a red light that blinks once on the CPU led shows up. There is so many things I find strange with this, first of all when the red light shows up the cpu fan kinda slows down sort of and the pc ussually after about 5-10 seconds instantly restarts itself. After that it boots past the BIOS option and freezes on the motherboard logo, then it restarts a couple more times and eventually freezes on the motherboard logo and thats all.. also sometimes it says that its preparing automatic repairs and then freezes (obviously).
The solutions I have tried
I have tried so many things so the chances are I am not gonna list them all here but the main ones are
  • Reset CMOS
  • Replaced the mobo battery for a 100% working one
  • Followed the ASUS Q-Led troubleshooting manual (reseated the cpu etc..)
  • Tried booting with one ram stick and with both
  • Updated BIOS
  • IT guy tested all the components individually (all working well)
  • Disabling secure, fast boot
  • Checking all the CPU pins
  • Returning the motherboard (because I thought it was faulty)
  • Running the PC without the peripherals (keyboard, mouse)
PC Specs
CPU - AMD Ryzen 3 3100
GPU - GEFORCE GTX 1650
RAM - HyperX Predator 16GB (2x8) DDR4
MOTHERBOARD - ASUS TUF Gaming B550M-plus

I would really like to get this sorted out, after a billion nerves lost and even more internet research I would probably find it a miracle to get this solved.
 

ASK THE COMMUNITY