[SOLVED] CS:GO Stuttering/Huge FPS Drops...

Jun 4, 2019
4
0
10
0
CS:GO Stuttering/Huge FPS Drops...

Not to long ago i completely reset my PC... After reinstalling windows and getting my programs reinstalled and stuff I installed CS:GO and set my game up to the way I play it. While playing i noticed HUGE fps drops and it's really annoying.
I average around 300 - 350 FPS while playing and i never experienced these drops before i reset my PC. I have tried many things to try and fix this problem and I can't seem to figure out the solution, So I came here to request help!

Another note: I'm not too sure if this only happens in CS:GO because I have no other games installed as of right now however I'm going to installed some games to test if they also stutter!

Here is some useful Info:

Specs:

CPU: Intel Core i7-8700K 3.70GHz
GPU: GeForce 1070ti
Ram: 16GB
OS: Windows 10
SSD: Samsung SSD 960 EVO 1TB x2

Any other specs i'm currently not too sure of but i'm 100% willing to find out if anyone needs them!
Same goes for any other information!

- Thanks in advance!
 
Jun 4, 2019
4
0
10
0
Make sure windows is fully up to date. One of the updates a couple of months ago caused random FPS drops in games. Ill see if I can find the KB article.

https://www.bleepingcomputer.com/news/microsoft/windows-10-kb4482887-cumulative-update-causing-major-stuttering-in-games/

Try a few of these solutions and see if they help: http://blog.drivethelife.com/windows-10/fps-drops-games-windows-10-update.html
Thanks for the help mate, However nothing seems to work... Since I posted this I have gathered more information and now know that it is not just CS:GO that stutters... I have no Idea what is wrong with it...
 
Okay, it could be some thermal throttling somewhere or HDD/SSD at 100% usage.

Run an instance of HWMon/info at idle/full load, and post screenshots of both. YOu can also set up MSI afterburner OSD to display in game metrics. Set it to show CPU Usage/temps, GPU usage/temps, system ram usage and FPS and frame time variance. This will show us what is happening in game. While you are gaming note if nything hits 100% usage and let us know.

Also, if you have anything OC'ed, run it at stock/ CPU/GPU.
 
Jun 4, 2019
4
0
10
0
While running a test with MSI afterburner there was no unusual activity! I'm not sure how to do this HWMonitor thing so a guide would be appreciated, along with what tabs to use!
 
Jun 4, 2019
4
0
10
0
Thanks for the help! I forgot to update this thread but the issue is now fixed, The problem lay with one of my SSDs and moving the game to the other has worked!


Thanks again for the suggestions and help!
 

ASK THE COMMUNITY

TRENDING THREADS