Question Dedicated GPU switches to integrated automatically in-game

Dxtr

Distinguished
Aug 17, 2014
22
0
18,510
0
Running on a Lenovo y50-70 laptop
Specs:
i7 4720HQ
16GB Ram
GTX 960m

After few mins of gameplay I always got a massive unplayable fps drops which lasts for about a minute ir two. In task manager performance tab it is seen that my 960m usage drops from 90+ percent to 10-40% and is replaced by a integrated one (Intel HD4600) which usage bumps to 60-80%

No thermal throttling has been found. This happens even at temperatures lower than 85 degrees.

Things I have tried:

PhysX processor set to 960m

Switching all the settings to maximum performance in power settings and nvidia control panel.

Performed a clean, updated, licensed windows install with latest clean installed drivers

Tried disabling Intel HD graphics which actually made things worse, 10fps tops.

setting priority to high

Using a cooler for laptop

Looking forward to hear any ideas.
 
Jan 21, 2022
46
1
35
0
Running on a Lenovo y50-70 laptop
Specs:
i7 4720HQ
16GB Ram
GTX 960m

After few mins of gameplay I always got a massive unplayable fps drops which lasts for about a minute ir two. In task manager performance tab it is seen that my 960m usage drops from 90+ percent to 10-40% and is replaced by a integrated one (Intel HD4600) which usage bumps to 60-80%

No thermal throttling has been found. This happens even at temperatures lower than 85 degrees.

Things I have tried:

PhysX processor set to 960m

Switching all the settings to maximum performance in power settings and nvidia control panel.

Performed a clean, updated, licensed windows install with latest clean installed drivers

Tried disabling Intel HD graphics which actually made things worse, 10fps tops.

setting priority to high

Using a cooler for laptop

Looking forward to hear any ideas.
Might be some hardware issues.
 

Dxtr

Distinguished
Aug 17, 2014
22
0
18,510
0
Check system logs to see if there are messages in there about Nvidia drivers crashing. Your game/DX may be automatically switching over to IGP because your GPU bleeped out of existence for a few seconds.
Okay I will do some testings and let you know.
Btw nvidia control panel was crashing before i reinstalled windows, even after performing clean drivers install. There was no chance to manage 3D settings. But now looks that working correctly. Had a clue that there might be a problem, but now seems like it was not a issue.
 

Dxtr

Distinguished
Aug 17, 2014
22
0
18,510
0
Well, only the strange thing Ive found is bunch of warnings with different processors. Looks like this:

The speed of processor 4 in group 0 is being limited by system firmware. The processor has been in this reduced performance state for 71 seconds since the last report.
 

Dxtr

Distinguished
Aug 17, 2014
22
0
18,510
0
Okay so that was not a hardware issue. Changed my heatsink plus bought a cooling pad and surprisingly with these 2 things the average temperature in-game dropped for almost 20 degrees celsius. Problem Solved.
 

ASK THE COMMUNITY

TRENDING THREADS