Question Doing MB test of new build - CPU light is on after flashing BIOS, and screen is black


Aug 22, 2019
Relevant Parts:

Ryzen 5800x
MSI B550 Tomahawk
Corsair Vengeance Pro RGB
Corsair RMX 850

I've completed the MB for my 2nd build (CPU + cooler, GPU, M.2 storage, and RAM attached) and I figured now is a good time to test that everything works before I put it in the box.

When I first connected everything to the PSU and powered on with a screwdriver, I got the DRAM debug light on. Reseated the RAM, the issue persisted, and I checked online. I saw mentions that I might need to update the BIOS for the 5800x, so I downloaded the latest version on the MSI site, downloaded it into an empty FAT32 USB, renamed it to BIOS.ROM, plugged it into the appropriate USB slot, flipped the power switch, and pressed the flash button.

The BIOS LED flashed for about 5-6 minutes, during which time the MB powered on (fans and LEDs turned on, as well as the RAM and GPU).

Now, the DRAM light is gone, but the CPU debug light is on, and I still don't see anything on my monitor (yes it's plugged into my GPU and all that). I removed my CMOS for a couple of minutes (after turning off the power and unplugging the PSU from the wall), put it back in, and tried again - still nothing.

I'm 99% certain the CPU is properly seated, so what might be the problem?

Edit: I tried the BIOS flash again (same version) and this time, the flash LED just stayed constant, and after a few minutes I powered down).
Last edited: