Ethernet connection stopped working. Anyone help?


Aug 18, 2011

I have a back-up shuttle PC and use it several days a week with an ethernet cable that fits into a Netgear router (It is not wireless). Suddenly the connection stopped, and so I tried several different cables (8 in fact!) but there is still no connection: the router does not acknowledge the ethernet cable is plugged into the shuttle ethernet port (only one port is valid) and the blue flashing lights on the shuttle no longer acknowledge a cable is plugged in. (As stated, the cable only works on the one port on the PC. Despite this, I have tried it on the other and while the lights on this port flash, no connection is established). However, all the cables and the router work without any problems on my other PC.
And yet when I stretch the ethernet cable to a really extreme position on the shuttle, the ethernet port lights flash and the connection is established until I let go of the wire. So, if the fault does not lie with the cable (having tried so many), and as I have checked the fitting of the card into the PC (which is tight and looks fine), can I assume it is the card that needs replacing?

Many thanks to anyone who can help.

PS. Sorry if I have used incorrect terms here, but I have little knowledge of this subject.


Most likely it is a hardware problem with the Shuttle Ethernet port, since moving the port by placing stress on it gets some evidence of trying a connection. The cheapest solution if you have wireless would be to use a wireless USB adapter (Newegg has a good TP-Link adapter for $10 on sale now: Your other choice is a new Ethernet adapter using a card or USB adapter:

I've used many of both the adapters and they work well with far less install effort.