Question Ethernet dropping when gaming and never reconnects until a full power drain of pc

Mar 10, 2021
2
0
10
0
Hi! First post on this forum so I apologise in advance for any shortcomings of etiquette!

I've been having a problem with my ethernet disconnecting ever since I bought my current build approx 4 years ago.

The ethernet connection will remain on and function normally 99% of the time while I browse the web, play browser based games, watch youtube. However, In almost every single game I launch from a platform like steam, blizzard, battle net, a direct game app or even certain programs that connect to the internet . Roughly 25% of the time my internet will disconnect after anywhere from 5 minutes of joining up to sometimes rarely letting me play or work almost a whole day. If I leave the game or app it will 95% of the time drop my ethernet. Very rarely will it continue to work as it should.

Oddly, when i first moved home with a new ISP but the exact same equipment on my pc, I had about a 2 week period where I could play games and work without any problems. This made me believe the problem had gone, yet it is back and happening on the same regularity it was in my previous home and has been doing so for months now.

The peculiar thing about it is that when the ethernet disconnects, It will never reconnect unless I power down my pc and drain power from it by switching the PSU switch off and holding the pcs power button down for a few seconds.

When I experience the ethernet drop after gaming or working, I have tried reinstalling network adapter drivers, A complete fresh boot of windows, unplugging the ethernet and plugging into different sockets on the router, restarting the router, different ethernet cables, contacting my ISP to see if they could help and even moving home with a complete new ISP yet the problem persists.

Absolutely nothing i have tried so far can make my pc reconnect to the internet when it has dropped except power draining the pc. Once it has been drained it starts up no problem and runs fine until I try use the offending apps and provoke the ethernet gods.

Any help would be greatly appreciated, It's legit turning me grey!

System info

MOBO: ROG Strix X470-f Gaming
CPU: ryzen 2700 x
GPU: gtx 1070
OS: Windows 10
 
Last edited:

Ironarmygeneral

Honorable
Jan 21, 2015
270
0
10,810
16
I can't say for sure without knowing more about your setup and hardware, but if I had to take a guess it's probably got something to do with a fauly ethernet port or its getting a power surge from somewhere (ethernet is typically low voltage cable).

Do you have any POE (power over ethernet) systems close to your router on your network for any reason? How old is the router/modem/access point? Do you already have, or have you tried, having any other devices plugged in via ethernet? If so, do they have the same issues? Does your wireless connection on other devices work fine when your computer drops ethernet connection?
 
Mar 10, 2021
2
0
10
0
I can't say for sure without knowing more about your setup and hardware, but if I had to take a guess it's probably got something to do with a fauly ethernet port or its getting a power surge from somewhere (ethernet is typically low voltage cable).

Do you have any POE (power over ethernet) systems close to your router on your network for any reason? How old is the router/modem/access point? Do you already have, or have you tried, having any other devices plugged in via ethernet? If so, do they have the same issues? Does your wireless connection on other devices work fine when your computer drops ethernet connection?
Thank you for your reply.

I do not have any POE systems on the network.

The router was brand new as of 4 ish months ago.

In my previous home I had two pcs connected via ethernet and only this computer had the issue. I did try switching ethernet cables and ports but the problem persisted regardless.

When my internet drops in both my previous and current home, only this pc is affected. All other devices will work normally.

As for my setup I am using:

MOBO: ROG Strix X470-f Gaming
CPU: ryzen 2700 x
GPU: gtx 1070
OS: Windows10
PSU: 750W Corsair(not sure specific model)

Thanks again!
 

ASK THE COMMUNITY