Question Fans and RGB run when the system is off

Dec 4, 2019
2
0
10
0
I recently updated the CPU, Motherboard, and RAM on my system. I am now running a Ryzen 7 2700x on an MSI b450 Tomahawk with 16GB GSKill Ripjaws DDR4 3200. The system boots and runs without error. However, when I shutdown the system all fans and RGB's on the entire system run at full blast; even a set of fans that are connected directly to the power supply do this, but did not before and I didn't touch their cables when upgrading. I tried flashing the BIOS and/or clearing the CMOS. No change. Thoughts? Help? Suggestions?
 

delaro

Splendid
Herald
BIOS

Check your BIOS for an ERP or ErP setting and disable it.

disable "Wake on USB" if that didn't work

If those didn't work then.

  • In Windows Control Panel, locate the Power Options settings
  • Hardware and Sound > Power Options > Edit Plan Settings).
  • Click on "Change advanced power settings" and locate the USB settings.
  • Disable the "USB selective suspend setting
 
Reactions: JTBell94
Dec 4, 2019
2
0
10
0
Thank you for your replies, the ERP was already disabled, as was wake on USB. I tried changing the wake on to OS instead of BIOS and saw no change. I also changed the USB selective suspend setting as suggested, no change. As for the OS, I have not reinstalled it after changing parts, I didn't think it could cause this but if you believe so I can give that a try when I have more time. I noticed something I didn't see before, on the Mobo there is an EZDebug LED. When the PC is off, the LED for the CPU is lit. When you power on that goes away.

Old parts that changed -

CPU: AMD FX 8320E
Mobo: Gigabyte 970a
RAM: 16GB Gskill Ares DDR3 2133
Cooler: Hyper evo 212

Current parts -

CPU: Ryzen 7 2700x
Mobo: MSI b450 Tomahawk
Ram: 16GB Gskill ripjaws DDR4 3200
SSD/HDD: Corsair 120GB SSD for OS, Seagate barracuda 4TB HDD, and Western Digital 1TB HDD
GPU: Powercolor RX 580 Red Devil
PSU: Corsair CX650M
Cooler: Wraith Prism that came with the CPU
Chassis: Rosewill Tyrfing ATX Midtower
OS: Win10 Home

Note: this is my first time using the forums here so please forgive any etiquette mistakes, thank you.
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts