• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!
May 25, 2020
2
0
10
0
Hi all, my first post to this site however I’ve followed this site for quite a while and you all seem friendly enough.

So I am currently having issues with my new pc from PCSPECIALIST and here’s why.

First of all, when I purchased the PC the CPU would hit 100c on idle desktop, after I changed the thermal paste it seemed fine but that was only the first fault.

Second and main fault are the GPU’s, I can’t run many games old and new past 60fps on high-ultra which may seem reasonable but here’s the build:

AROUS Master Z390
I9-9900k
64gb Corsair vengeance 3200mhz
2x 2080 ti’s
Corsair gold modular 1000W

Now I’ve been to a few threads and a lot of people get angry and moan that people are just showing off but this is a genuine fault I believe. My pc won’t even push past 50fps on red dead 2 on high or ultra when I have seen people getting 100+.

If anyone has any ideas I’d love to hear them as I’m quite disappointed.
 

Wolfshadw

Titan
Moderator
ASUS Z390 AORUS Master - Motherboard Manual

Are the two graphic cards installed in the first and second PCI-Ex16 expansion slots?
Do you have the NVLink Bridge installed?
Did you set up SLI in settings (ref Pg 20 of the manual)?

Geforce GTX 2080Ti - Specs
@kurdtnz - Yes, 1000 watts should be enough. NVidia Recommends a 650 watt PSU for a single card and the typical draw is only up to 260 watts.

-Wolf sends
 
Reactions: kurdtnz
May 25, 2020
2
0
10
0
The company online recommended 1000w as the max power will be 914w for the whole system, yes a nvidia sli bridge was installed and set up by them and I did go over the settings myself too, I’ve taken the sli bridge off as well to test and it has the same effect, the cards are in the correct slots aswell
 

ASK THE COMMUNITY