Question GPU BUS PROBLEM

Oct 28, 2021
4
1
15
0
Hello,
I have one question. When I play Assassin's creed Odyssey as it runs "smoothly" with 40-60fps on medium settings 720fps, the game drops to 15-20fps at random, bus usage jumps from 20% to over 65 and the GPU and CPU ms jump from 20 to 50-60. But the gpu usage stays at 95-100%.
I am using msi afterburner at max core voltage and max power limit.
Temps stays at 85 or something like that so I think it's not slowing down to cool.
I know that gpu bus is how much data is being sent to/from the gpu but don't know why it starts dropping fps.
Best regards.

PC specs:
CPU: AMD RYZEN 7 3700x
GPU: MSI GTX 670
RAM: HYPERX FURY 2x8GB 3200MHz
PSU: COOLER MASTER MWE GOLD 750W
MOTHERBOARD: GIGABYTE X570 UD
GPU DRIVERS: 472.12
 

keith12

Illustrious
Hey there,

Not trying to be contrary, but, you haven't asked a question :) What exactly is it you want to know? Is it to do with frame drops, GPU usage?

I think you may be talking about frame-time spikes, but really I'm not sure. Perhaps you can clarify a little.
 
Oct 28, 2021
4
1
15
0
Hey there,

Not trying to be contrary, but, you haven't asked a question :) What exactly is it you want to know? Is it to do with frame drops, GPU usage?

I think you may be talking about frame-time spikes, but really I'm not sure. Perhaps you can clarify a little.
Yes, I am wondering why this is happening because it is really annoying and need to restart the game to fix it. 🙂
 

keith12

Illustrious
I guess it's possible it's GPU. It's pretty old now, and it may be throttling (getting too warm and reducing clockspeeds). Temps ar 85c are defo on the high side. Normally you can expect your GPU to be hovering around the 70c mark while gaming.

Have you cleaned the GPU at all/ever? It could be dust building up, causing fans to spin up to 100% just to try keep pace. I'd start there. Take the GPU and give it a good clean with compressed air.

Reset MSI to default (no max power), what temps do you get? Is the stuttering frame time spikes still happening?

It could also be the game you are playing, and the res you are playing at. The 670 is limited by it's ram for modern games. Is vram usage maxed out? That could also be the issue.
 
Oct 28, 2021
4
1
15
0
I guess it's possible it's GPU. It's pretty old now, and it may be throttling (getting too warm and reducing clockspeeds). Temps ar 85c are defo on the high side. Normally you can expect your GPU to be hovering around the 70c mark while gaming.

Have you cleaned the GPU at all/ever? It could be dust building up, causing fans to spin up to 100% just to try keep pace. I'd start there. Take the GPU and give it a good clean with compressed air.

Reset MSI to default (no max power), what temps do you get? Is the stuttering frame time spikes still happening?

It could also be the game you are playing, and the res you are playing at. The 670 is limited by it's ram for modern games. Is vram usage maxed out? That could also be the issue.

Thanks for the tips, I’ve cleaned it before 4/5 months. Max temp of the card is 98 degrees so that’s why I am thinking it’s not throttling. The game is using 1800/1850mb from 2042. I will try cleaning it, and resetting the msi afterburner.
Best regards
 
Oct 28, 2021
4
1
15
0
Let us know how you get on.
Hello,
So far I think we fix the problem.
Today I cleaned the PC and especially the GPU. As you know MSI GTX 670 is closed GPU with only 1 fan and small amount of dust came out. But surprisingly there are no spikes in AC Odyssey so far (I have played 2-3hours). I wasn't thinking that it was throttling because for example in The Forest the temps were 91-92 and there wasn't any going back from the card and on AC Odyssey the temps were 86/87. Now GPU is staying in solid 80 temps, in The Forest the temps are 80-82/3.
So maybe the problem was throttling .
Best regards

P.S in AC Odyssey there is no difference in using +100 Core Voltage and 122 Temp or stock.
 
Reactions: RodroX

keith12

Illustrious
Hello,
So far I think we fix the problem.
Today I cleaned the PC and especially the GPU. As you know MSI GTX 670 is closed GPU with only 1 fan and small amount of dust came out. But surprisingly there are no spikes in AC Odyssey so far (I have played 2-3hours). I wasn't thinking that it was throttling because for example in The Forest the temps were 91-92 and there wasn't any going back from the card and on AC Odyssey the temps were 86/87. Now GPU is staying in solid 80 temps, in The Forest the temps are 80-82/3.
So maybe the problem was throttling .
Best regards

P.S in AC Odyssey there is no difference in using +100 Core Voltage and 122 Temp or stock.

Glad you got it sorted! :) Happy gaming!
 
Reactions: ElDochini

ASK THE COMMUNITY

TRENDING THREADS