Question HDD won't appear in boot menu

Sep 14, 2019
8
0
10
0
Hey guys. I got a new Asus rog strix z-390-e mainboard and I want to boot Windows 10 from the HDD I used before, but it won't show up in the boot menu. What's weird is that it appears in Storage information, so I'm guessing it's connected and working properly. Can anyone help me out?
 

Joakim Agren

Proper
Sep 5, 2019
139
18
115
7
Have you tried booting it in safe mode? Boot into safe mode with network and download all the drivers for your new system and install them in safe mode. Then re boot normally and hopefully all will work!
 

Joakim Agren

Proper
Sep 5, 2019
139
18
115
7
Thanks for the quick reply. Can I do that from UEFI? Because I can't get past the UEFI screen.
If you can not get into the boot options by pushing F8 with 1 second intervalls during POST then you can try holding down the power button for 3-5 seconds to power down the system. Once powered down then directly power it on again and then directly power it off again. repeat this process 3 times. This will usually force boot options to show up!
 
Sep 14, 2019
8
0
10
0
Pressing F8 brought up another window. It says "please select boot device" but there I can't choose any option other than "Enter Setup", which just brings me back to the UEFI screen.
 

Joakim Agren

Proper
Sep 5, 2019
139
18
115
7
Pressing F8 brought up another window. It says "please select boot device" but there I can't choose any option other than "Enter Setup", which just brings me back to the UEFI screen.
Perhaps your old drive are using the Legacy boot Master Boot Record (MBR) boot method but the new motherboard is set at default to boot into the more modern UEFI boot.

In Asus BIOS go to the BOOT menu and select Secure Boot and here select Other OS under OS Type. Then next go to the CSM setting and on the following page make sure that auto is selected under launch CSM. Then save and exit BIOS and try again to boot into the drive.
 
Sep 14, 2019
8
0
10
0
Under Launch CSM I can only choose between Enabled and Disabled. I'm guessing auto = enabled. When I choose Enabled, 4 more options pop up:

  • Boot Device Control, which is set to "UEFI and Legacy OPROM"
  • Boot From Network Devices, which is set to "Legacy only"
  • Boot from Storage Devices, which is set to "UEFI only"
  • Boot from PCI-E/PCI Expansion Devices, which is set to "Legacy only"
 

Joakim Agren

Proper
Sep 5, 2019
139
18
115
7
Under Launch CSM I can only choose between Enabled and Disabled. I'm guessing auto = enabled. When I choose Enabled, 4 more options pop up:

  • Boot Device Control, which is set to "UEFI and Legacy OPROM"
  • Boot From Network Devices, which is set to "Legacy only"
  • Boot from Storage Devices, which is set to "UEFI only"
  • Boot from PCI-E/PCI Expansion Devices, which is set to "Legacy only"
Yes you found the spot. Change this option "Boot from Storage Devices, which is set to "UEFI only" " to Legacy Only instead then save and exit BIOS and try to boot.
 
Sep 14, 2019
8
0
10
0
Thanks but sadly this is where it gets frustrating. Most changes I make to UEFI will cause the following message to appear directly after rebooting (even before POST): "please power down and connect the PCIe power cables for this graphics card".

This means that I have to reset CMOS every time I get this error message, because I haven't found another way to get past it. Which, of course, resets any changes I made as well.

And I've checked the PCI cables countless times and it's all connected.

Sorry for all of this....
 

Joakim Agren

Proper
Sep 5, 2019
139
18
115
7
Thanks but sadly this is where it gets frustrating. Most changes I make to UEFI will cause the following message to appear directly after rebooting (even before POST): "please power down and connect the PCIe power cables for this graphics card".

This means that I have to reset CMOS every time I get this error message, because I haven't found another way to get past it. Which, of course, resets any changes I made as well.

And I've checked the PCI cables countless times and it's all connected.

Sorry for all of this....
When you get this error message turn off the computer by holding down the power button for 3-5 seconds. Once turned off pull the power plug then turn the power supply on and off multiple times until you see that the fans and led's stops reacting. That is an indication all power have been drained from the PSU. Then put the power cable on again, put it to ON and try to boot again... Sometimes this works....
 

ASK THE COMMUNITY

TRENDING THREADS