HELP: Combine a non-RAID and RAID1 Sata disks on Abit AW9D


Dec 13, 2006
Hi experts.

I have buid a new PC using Abit AW9D mobo, and 3 Sata Disks.
First disk is a single 10.000 rpm Raptor SATA disk for OS and apps.
The 2 other disks are 500GB Sata disks that I want to use in Raid1 mirror mode for data storage.

My problem is:
How to setup BIOS right, to let it know that not ALL 3 disks shold be using Raid. OS is installed already and working. If I change the current "IDE" setting in "On-Chip Sata Mode" under "On-Chip IDE Device" in "Integrated Peripherals" to "Raid" - all 3 disks then occur in the Intel Raid BIOS, and OS will then bluescreen crash, when trying to boot again.
The 2 500GB disks are configured as "Raid1" in Intel Raid BIOS, and the single disk appers as "Non-Raid disk" which is right.

Has anyone got this combination of a single Sata disk with 2 disks in Raid with this mobo? I have tried all Sata Connectors, and have always checked the Hard disk priority order i BIOS, when trying to boot again. The single disk is first boot disk!

Thanks in advance.


Sep 13, 2006
I'm in almost the same exact boat. I have a raptor 150gb as my primary boot device with already installed windows xp pro sp2 and various programs. I wanted to raid my two samsung spint point p's. But, anytime I try, the thing won't load windows and goes into windows fail safe selection mode, then reboots.

I've asked on abit-usa's forums and people keep telling me that it should work as long as I don't make the raptor as part of raid array (which it isn't) and as long as I make sure the raptor is listed as primary boot device (it is).

But I still get no luck. Here's my thought, but no one has said its right and no one has helped: I think that by leaving it at "auto" under the BIOS, the drives are operating as IDE devices, meaning kinda like "dumb" devices for which no drivers are needed. But, when you tell the BIOS to switch to RAID, it initializes all 4 sata ports under the intel controller (not all 4 raid, just all 4 as no longer default ide devices), and thus you need the intel drivers installed. I say this cuz it looks this way, and also cuz I've tried choosing not raid, but AHCI (the thrid option under the BIOS), which results in the same problem.

So, you can try to install the drivers. I've tried, boy have I tried! But the drivers won't install. look in you manual, which lists the intel matrix sotrage driver and also the intel chipset software install untility. the Software install utility must be installed before the matrix techonolocy driver. Done, I've used the cd and intel's website download to intall the software utility (or so I think, but no verification). Then I go to install the matrix driver (which my abit cd doesn't have listed on its autorun page, but have to manually select it with "explore cd"). Anyway, I try using that driver install and it spits back that no install can occur my system doesn't meet the minimum system requirements. So, I try the intel website to download the driver matrix technology driver and install and it gives me the same message of not meetin minimum system requirements!!!

I've gone thru the system requirements and meet all of them. So either its a sick game intel/Abit is playing, or somethign which I think is there is not there. I'm guessing its the chipset software utility not fully installing, but no way to verify this either way.

So, I've sent an email to Abit tech support, but its too early for them to have gotten back yet. THe users on Abit's forums are trying to help, but no luck yet. I posted here before seeing your post. And also over at Anandtech. You should put in a request to abit tech support since this may be a problem that affects more than me, and now you.

also, I have tried using the intel raid diskette to manually transfer drivers, but my other computer says it is blank and ask if I want to format it!!! (explanation: my new rig no has a disk drive, so I was gonna use my old rig to transfer diskette contents to a usb flash drive and migrate them that way under windows, but my old rig says this disk is blank!!!).

You can try any of the above and see if it works for you. Otherwise, please notify Abit and also keep posting. If you get anywhere, let us (especially me!) know.

good luck,

curt j.


Sep 13, 2006
Okay, about the last post I made is now confirmed as accurate by Abit Tech Support and Intel knowledge base:

Dear Customer,

Is all 3 hard drive connect to SATA 1~4 ports? These ports are controlled by the Intel chipset.

When using RAID or AHCI configuration, proper driver is required during windows installation process. Switching the SATA mode after installed the windows will cause the system not function properly.

Please use the supplied driver disk to load the RAID or AHCI driver during windows installation by pressing F6. This is required by Microsoft's standard windows installation process. Therefore, the floppy driver disks are included in the retail packaging.

The installation disk files are also available on our website for download .

Since there's 3 hard drive in this hardware configuration. The system will still work with 1 hard drive operate as single RAID disk and 2 other hard drive in desired RAID array.

If you have any questions, please let us know
Thank you

Best Regards,

Abit FAE Team​

So, when the intel chipset initializes raid it makes all its ports switch from the IDE driver to another, thus requiring new drivers be installed.

This makes sense in a weird way, that the chip was designed poorly where all 4 ports are either all "on" or all "off" and the workaround is obviously to reinstall os with using F6 method to install drivers when os loads. I just wish this was made clear (or even unclear, but mentioned somehow!) from the start. THe manual even says only need floppy if making raid as os boot disk (see page 4-9 of my manual). As it is, the common wisdom on any intel ICH7R board (and others too) was to only install the drivers by F6 if yer gonna make yer boot disk as part of raid array. Nope, now gotta do it for all.

And this kinda means that if you don't install the drivers, all you're getting, and will ever get, is ide-type performance (see intel's website knowledge base). This might be a biggie for some and is not limited to Abit boards, but to any using the intel chipset, see Intel's knowledge base article.

So, this board officially would seem to require a floppy drive for install. No biggie, I mean if you can afford this mobo you can afford a floppy drive, I was just kinda hoping to have left the 80's in, well, the 80's.

curt j.