Help reading dmp files for bsod

aroband

Prominent
Sep 24, 2017
3
0
510
0
So for the past few weeks, I've infrequently been getting a bsod with the error "dpc_watchdog_violation." It sometimes happens every time I boot my computer and sometimes will run fine for days before crashing. I've tried everything I could find, from updating drivers, checking memory, even a full system reset, but nothing is working. I thought to use the dmp files to find the exact problem, but I kept having problems with that too. If anyone is able to look at the dmp file and tell me what is causing this error, I'd be grateful. I'm including a link to a zipped folder with the dmp file in it. Any help would be greatly appreciated.

https://www.dropbox.com/s/63dv5j8zr3zrx8h/091917-24437-01%20-%20Copy.zip?dl=0
 
you might have a usb device that is causing problems with your usb network driver.
you might put your usb device on a different port (usb 2 port if it is on a usb 3.0 port)

if you change the memory dump type to kernel, then the proper info can be read from the new memory dump file. C:\windows\memory.dmp (otherwise it is just a guess as to the real problem)

(stack was corrupted in the usb network driver)
netr28ux.sys Thu May 28 07:28:52 2015
Ralink RT2870 series USB802.11n Wireless Adapter Driver (you may have a different manufacturer)

NOTE: BIOS Version P7.20
BIOS Starting Address Segment f000
BIOS Release Date 11/22/2016
Manufacturer ASRock
Product Z170 Extreme4

update the audio driver:
http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=14&PFid=24&Level=4&Conn=3&DownTypeID=3&GetDown=false

and go into device manager and disable the gpu high def audio driver if you don't have speakers in your monitor that get the signal from the video cable.

this is a guess because of the GPU and audio calls just before the network driver data was corrupted.

- you might also go into bios and reset it to defaults and reconfigure so the bios rescans the hardware and updates the database of settings it sends to windows.
 

axe0axe0

Notable
Jun 5, 2017
761
0
1,160
96
@johnbl, you're sure it's a corrupted stack? Not an alternative of missing symbols, or just a lack of data as it's a minidump?

Netr28ux.sys is a network driver. I do know Intel doesn't use this driver and the Intel lan device is the only network device for this motherboard.
The chipset drivers being involved make sense with a USB network driver.

@aroband, check if Ralink (or the manufacturer of Ralink is not the manufacturer) has driver updates. If there are no driver updates and reinstalling doesn't help, try the USB adapter in either a different USB port or a different system.
 
http://www.carrona.org/drivers/driver.php?id=netr28ux.sys
if the usb device is on a usb 3 port, move it to a usb 2.x port
(just as a guess that is problem with the usb 3.0 port )

list this as a Ralink RT2870 usb wireless driver.
----------------
the kernel dump might be more useful to see what is going on with the other cores but here is what the minidump had:


# Child-SP RetAddr Call Site
00 fffff800`13117bc8 fffff800`10da8568 nt!KeBugCheckEx
01 fffff800`13117bd0 fffff800`10c81d49 nt!KeAccumulateTicks+0x124b88
02 fffff800`13117c30 fffff800`11498676 nt!KeClockInterruptNotify+0x599
03 fffff800`13117f40 fffff800`10c1b675 hal!HalpTimerClockInterrupt+0x56
04 fffff800`13117f70 fffff800`10d79c1a nt!KiCallInterruptServiceRoutine+0xa5
05 fffff800`13117fb0 fffff800`10d7a067 nt!KiInterruptSubDispatchNoLockNoEtw+0xea
06 fffff800`13107b50 fffff80f`c608343b nt!KiInterruptDispatchNoLockNoEtw+0x37
07 fffff800`13107ce0 fffff80f`c60824b2 ndis!ndisNblTrackerTransferOwnershipInternal+0x113
08 fffff800`13107d40 fffff800`25a5099e ndis!NdisMIndicateReceiveNetBufferLists+0x542
09 fffff800`13107f30 ffff838d`be400000 netr28ux+0x1099e
0a fffff800`13107f38 00000000`000000ff 0xffff838d`be400000
0b fffff800`13107f40 00000000`00000002 0xff
0c fffff800`13107f48 00000000`00000018 0x2
0d fffff800`13107f50 ffff838d`00000000 0x18
0e fffff800`13107f58 ffff838d`c0509000 0xffff838d`00000000
0f fffff800`13107f60 00000000`00000500 0xffff838d`c0509000
10 fffff800`13107f68 fffff800`25a5d1b8 0x500
11 fffff800`13107f70 ffff838d`c0509000 netr28ux+0x1d1b8
12 fffff800`13107f78 fffff800`131080e0 0xffff838d`c0509000
13 fffff800`13107f80 fffff800`25c09158 0xfffff800`131080e0
14 fffff800`13107f88 ffff838d`c0159600 netr28ux+0x1c9158
15 fffff800`13107f90 ffff838d`c0159650 0xffff838d`c0159600
16 fffff800`13107f98 fffff800`00000001 0xffff838d`c0159650
17 fffff800`13107fa0 ffff838d`bff34e00 0xfffff800`00000001
18 fffff800`13107fa8 fffff80f`c42f0e2f 0xffff838d`bff34e00
19 fffff800`13107fb0 fffff800`10cd34f5 Wdf01000!FxWakeInterruptMachine::processEventInner+0x17 [minkernel\wdf\framework\shared\irphandlers\pnp\wakeinterruptstatemachine.cpp @ 288]
1a fffff800`13107fe0 fffff800`00000000 nt!IoReuseIrp+0x115
1b fffff800`13108080 ffff838d`c0159650 0xfffff800`00000000
1c fffff800`13108088 ffff838d`c015962c 0xffff838d`c0159650
1d fffff800`13108090 fffff800`00000000 0xffff838d`c015962c
1e fffff800`13108098 ffff838d`c0159630 0xfffff800`00000000
1f fffff800`131080a0 ffff838d`01010001 0xffff838d`c0159630
20 fffff800`131080a8 fffff800`25c43ac0 0xffff838d`01010001
21 fffff800`131080b0 00000000`00000b58 netr28ux+0x203ac0
22 fffff800`131080b8 ffff838d`c0509000 0xb58
23 fffff800`131080c0 00000000`00000000 0xffff838d`c0509000
 

I dumped the raw stack, saw the audio call, video call and the usb3 hub and along with the netr28ux.sys
calls. Since the netr28ux.sys was from 2015 I would guess that it has already been updated.
that is why I suggested changing the port from usb 3. to usb 2, update the motherboard audio, and disable the gpu high def audio. Most are just a guess as to something to try.


I could not see what is going on with the other cores, Need a kernel dump to check for common plug and play issues, and old devices installed on the USB ports. (to check for old mouse with old broken firmware type problems) Or plug and play attempting a install on one core while the device is being used on another core type problem.


 
you might also go into your bios and see if you can prevent your usb ports from going to sleep. (or go into device manager, right mouse click on the usb ports and find the power management tab and see if you can block the sleep functions. (just a guess at something that could be triggering the problem with the network driver.
-----------
you also have a device that failed after it was started:
USB\VID_0000&PID_0002\5&c94d647&0&6
here is the list of devices that did not fail:
Desc: A6210
USB\VID_0846&PID_9053&REV_0100 NETGEAR, Inc.

Desc: USB Receiver
USB\VID_046D&PID_C531&REV_2100 Logitech Inc.

Desc: BCM20702A0
USB\VID_19FF&PID_0239&REV_0112 Best Buy China Ltd.

Desc: Gaming Keyboard G910
USB\VID_046D&PID_C335&REV_0602 Logitech Inc.


here is the one that failed:
Current Device State: EnumeratedAsFailedUnknown.WaitingForDevicePortEventsForFailedDevice
Desc: <none>
USB\VID_0000&PID_0000&REV_0000 Vendor ID not listed with USB.org
!wdfhandle 0x37ff66a122d8 (UCXUSBDEVICE)Error: Unable to get USBDEVICE_DATA context for wdfhandle 0x000037ff66a122d8

looks like the device stopped responding, the usb tried to reset the port and the device just never recovered.



stack shows calls to the
\SystemRoot\System32\drivers\USBXHCI.SYS
(date time stamp messed up)
just before it made calls to
\SystemRoot\System32\drivers\netr28ux.sys Thu May 28 07:28:52 2015
then a bugcheck.

your motherboard uses a usb 3.1 chip
http://www.asmedia.com.tw/eng/e_show_products.php?cate_index=160&item=161
this chip requires updates for its firmware or from the bios.

since it looks like you are using the windows 10 generic usb extension files, you might require a update to your bios (which is current) or a special firmware update to the chip itself. I can not tell. or it can just be a bug in the USB wireless driver.

since your wireless driver is older (usb 3.0) days it could also be a bug in that driver. just very hard to tell. media tek now owns the company that used to make the chip and drivers for you usb wireless device. getting updates might be hard. I did not see any drivers on their website. https://www.mediatek.com/products/connectivity-and-networking/broadband-wifi
maybe the actual vendor of the usb device will have a update on their website.

you might also be able to go into bios and find a option to turn off the usb extensions so your usb chip acts as a standard usb device. or put your usb device on a usb 2.x hub
machine info:
BIOS Version P7.20
BIOS Starting Address Segment f000
BIOS Release Date 11/22/2016
Manufacturer ASRock
Product Z170 Extreme4
Processor Version Intel(R) Core(TM) i5-6500 CPU @ 3.20GHz
Processor Voltage 8ah - 1.0V
External Clock 100MHz
Max Speed 5000MHz
Current Speed 3200MHz


 

Similar threads


ASK THE COMMUNITY