Question How to stop AMD Ryzen CPU from changing frequency while gaming?

AnthonyLF1025

Reputable
Apr 6, 2017
7
0
4,510
0
I've noticed while gaming that my Ryzen 5 2600 is changing the cpu core clock and I THINK its causing bad microstutters. It go's from 3775Mhz to let's say, 3750MZHz and I notice i drop a couple frames but the stuttering is terrible. I overclocked my cpu to 4100Mhz the other day and noticed the stutters didn't happen anymore and the core clock never changed from 4100MHz. I don't know if it's a coincidence or that's what is actually happening.

Now, would it be possible to stop the frequency from changing without overclocking? I think the base speed is 3400MHz but it has a boost that makes it go to 3775MHz while gaming. Would it be possible to lock the core clock to 3775MHz without overclocking it? Like disabling a power saving feature to stop the clock from changing? I'm using the stock cooler and haven't had much success overclocking. I can't get the voltage right or the temps are too high and i'm not too informed on it, so i really don't want to mess with it.

Specs,

CPU : Ryzen 5 2600 (stock)
GPU : RX 570 4GB
RAM : 16gb 2993mhz (XMP enabled)
PSU : Corsair CX 550.
MOBO : Asrock b450m pro4
 

AnthonyLF1025

Reputable
Apr 6, 2017
7
0
4,510
0
Just set a multiplier of 37.75 (for 3775Mhz) and that will be the fixed clock it operates at. Use the same BIOS control you used to set it to 4100Mhz.
Okay. Just wondering because i don't know alot about overclocking, would i need to adjust the voltage? I bought this pc from someone and he told me he could get it to 4.1Ghz with 1.35v but it would crash for me after doing a stress test and would get pretty hot, so i haven't messed with it since.
 

hotaru.hino

Respectable
Sep 1, 2020
1,843
575
2,340
76
I'm willing to wager this has more to do with the threads bouncing across CCX domains than frequency shifting. There's a non-trivial penalty for accessing data between CCX boundaries. Considering the 2600 is based off Zen, I believe the data here is still relevant: https://www.tomshardware.com/reviews/amd-ryzen-5-1600x-cpu-review,5014-2.html

You could try to see if setting the processor affinity to half the threads can help. This should keep everything on one CCX.
 

AnthonyLF1025

Reputable
Apr 6, 2017
7
0
4,510
0
I'm willing to wager this has more to do with the threads bouncing across CCX domains than frequency shifting. There's a non-trivial penalty for accessing data between CCX boundaries. Considering the 2600 is based off Zen, I believe the data here is still relevant: https://www.tomshardware.com/reviews/amd-ryzen-5-1600x-cpu-review,5014-2.html

You could try to see if setting the processor affinity to half the threads can help. This should keep everything on one CCX.
Thanks for responding. I'm not really advanced on any of this but do you mean going into the task manager and manually setting the processor affinity for a specific program , like fortnite for example or something different?
 

AnthonyLF1025

Reputable
Apr 6, 2017
7
0
4,510
0
Just set a multiplier of 37.75 (for 3775Mhz) and that will be the fixed clock it operates at. Use the same BIOS control you used to set it to 4100Mhz.
I just read this on reddit.

"I also had some luck by changing the clock speed multiplier on my CPU. The speed was all over the place and after I set the multiplier, it was much more stable and reduced a lot of the stutter & lag. "

He has same the issue as me and he is also playing fortnite. I'm not sure if this happens across multiple games but I encounter this issue in fortnite alot. The only other game i've played is Warzone and i haven't played it alot to know, but the stuttering isn't that bad when I have played it.
 
Okay. Just wondering because i don't know alot about overclocking, would i need to adjust the voltage? I bought this pc from someone and he told me he could get it to 4.1Ghz with 1.35v but it would crash for me after doing a stress test and would get pretty hot, so i haven't messed with it since.
Setting it to 1.35V is safe on a 2600 but I think you could get by just leaving it in AUTO for 3775Mhz.

I tend to think Nighthawk is right: whatever is causing your stuttering is somewhere else. But go ahead and try this if you want. It can't hurt, just really limit system performance by throttling it at a fixed clock well below it's potential.
 

AnthonyLF1025

Reputable
Apr 6, 2017
7
0
4,510
0
Setting it to 1.35V is safe on a 2600 but I think you could get by just leaving it in AUTO for 3775Mhz.

I tend to think Nighthawk is right: whatever is causing your stuttering is somewhere else. But go ahead and try this if you want. It can't hurt, just really limit system performance by throttling it at a fixed clock well below it's potential.
Alright. Just to be sure i'm doing this right, here's a screenshot of my bios.

View: https://imgur.com/a/VE37wgV


Would i just change the frequency and leave the voltage the same? Sorry btw for all these questions just barely know what i'm doing
 
Alright. Just to be sure i'm doing this right, here's a screenshot of my bios.

View: https://imgur.com/a/VE37wgV


Would i just change the frequency and leave the voltage the same? Sorry btw for all these questions just barely know what i'm doing
First thing is to note I've not used an Asrock BIOS so I'm assuming it works consistent with what I'm saying to do.

OK...the settings of interest is Frequency (Mhz) and Voltage (VID). In that picture your CPU Frequency is fixed at 3400Mhz and voltage is fixed at 1.1375V. That fixed frequency, the BASE clock speed, is WAY below performance capability of a 2600.

So if you want to try: change the Frequency to 3775Mhz and the Voltage (VID) to 1.350V. That voltage is probably more than needed but should be stable. The smart thing to do is iteratively test in a heavy load (something like Cinebench) while lowering voltage between tests until it crashes, then move voltage back up a couple notches. You want to find the lowest stable voltage.

That's not exactly "overclocking", at least as I see it, since the CPU will boost to 3900Mhz (or more) on it's own when properly set up in auto.

But what I SUGGEST is: Change Frequency to AUTO, and the Voltage (VID) to AUTO. Also, above the CPU Frequency (MHZ) setting, the line where it says "CPU Frequency and Voltage (VID)" and currently says MANUAL, just change that to AUTO. Do this before you do anything else and see if it fixes your stuttering. Only after checking that should you try anything else.

Typically, to change a setting you just click into the box, or hit arrow keys to get there, then hit + or - to increment/decrement settings or simply type in the value you want.
 
Last edited:

ASK THE COMMUNITY