Question Hyperx RAM not working anymore, only RAM's RGB light is turning on but no display ?

Oct 2, 2021
1
0
10
0
I've bought new HyperX DDR4 RAM for my PC. I installed it in my PC when It arrived and it worked perfectly, I didn't have any problems with it. Then one day I was playing a game when my pc screen froze, I couldn't do anything so eventually I shut it down from the button on my PC, I then pressed again and it wouldn't boot, the ram light is on but there's nothing on the screen.

I tried to boot with only one stick of ram but still didn't work, neither of them. I installed my old ram and it booted with no problem, I really wanna get this fixed as soon as possible. I'm thinking it might be because of the power supply not being powerful enough but I might be wrong. Any advices are welcomed!
 
I've bought new ram for my pc, it's from hyperX DDR4 I've installed it in my pc when It arrived it worked perfectly I didn't have any problems with it but one day I was playing a game when my pc screen froze I couldn't do anything eventually I shut it down from the button on my pc I then pressed again and it wouldn't boot the ram light is on but there's nothing on the screen I tried to boot with only one stick of ram but still didn't work neither of them. I installed my old ram and it booted with no problem, I really wanna get this fixed as soon as possible. I'm thinking it might be because of the power supply because it's not powerful enough but I might be wrong. Any advices are welcomed!
full pc specs?
 
Reactions: RodroX

mamasan2000

Distinguished
I've bought new HyperX DDR4 RAM for my PC. I installed it in my PC when It arrived and it worked perfectly, I didn't have any problems with it. Then one day I was playing a game when my pc screen froze, I couldn't do anything so eventually I shut it down from the button on my PC, I then pressed again and it wouldn't boot, the ram light is on but there's nothing on the screen.

I tried to boot with only one stick of ram but still didn't work, neither of them. I installed my old ram and it booted with no problem, I really wanna get this fixed as soon as possible. I'm thinking it might be because of the power supply not being powerful enough but I might be wrong. Any advices are welcomed!
You are not mentioning platform etc. Pls list your parts. RAM pulls around 3 watts. Can't be PSU. Unless it is a low quality one. Not because of watts.
Check your motherboard manual where the RAM sticks should go.
 

ASK THE COMMUNITY

TRENDING THREADS