Question I changed my system board on my laptop, now start-up is not showing Dell logo, among other problems.

Mar 24, 2019
1
0
10
0
Greetings!

I changed the system board on a Dell Inspiron 13 model 5368 because the old board went bad. Everything was working more or less swell except for the fact that the board was sent to me with manufacturing mode activated. So I followed these instructions ---> Dell Thinga-ma-jig
I did step 5 many, many times until the 'manufacturing mode activated' message went away, but the Dell logo doesn't come out either.

Now...
- The Bios can't update*
Installer will take me to this screen shown here, not progress, and system would restart. Msinfo will show bios has not updated.

- Both Bios Setup and Dell Diagnostics can't detect the charger (but battery can still charge by some miracle).

- Windows 10 will not detect my charger unless I restart the system with the charger plugged in (and battery will charge. Related to problem 2, I think)

- BIOS Version number showing weird version/date information (shown here on msinfo and here on the installer).

I tried the BIOS Installer. It used to say 'Dell System Unidentified System', before the 'manufacturing mode activated' message went away. Now the Dell system ID is as shown in the screenshot in problem 4. I was using the installer for the 5378 because the one for the 5368 would just say 'Error: unsupported system ID found', but my laptop was originally a 5368.

I also tried reformatting Windows because the computer was incredibly slow while I was trying to fix it. I tried unplugging the coin-cell battery for 15 mins. I suspect my charger is the culprit but I wanted to get more advice before I try to replace it. I suspect that my computer can't detect my charger because BIOS is not update - creating a vicious cycle of self-destruction.

Here's the my specs...
System board model 0P380W w/ i7-7500u (new)*
8 GB DDR3 SDRAM
Intel HD 520 Video Card
45 Watt AC Charger
256 GB SSD
Windows 10

*the old board was a model PJDNR w/ i7-6500u

Thank you for your time!
 
Last edited:

korv

Upstanding
Dec 26, 2018
363
26
340
13
well, of course it won't show the dells logo after you've changed the motherboard. Seems like your new motherboard costed you a lot of problems. i guess your old board was actually the key... well, i suggest to order the original motherboard and it should work, take it to a professional or anyone else here that is clever enough to solve this.
 

ASK THE COMMUNITY

TRENDING THREADS