Question Input Lag/Mouse Lag/Sluggish Mouse/ Floating Mouse

Aug 16, 2019
1
0
10
0
Specs +peripherals

SPECS
CPU- i9-9900k
GPU- MSI Gaming X Trio
PSU- RM850X
MOBO- Aorus Gigabyte
RAM- 32 DDR4 Vengeance LPX
CPU Cooler- Kraken x72
CASE- h700

PERIPHERALS
Mouse- Glorious model 0
keyboard- Ducky one 2 mini
Monitor- Alienware AW2518hf 1ms 240hz
Mic- blue yeti
headset- hyper x cloud II

My specs are top tier why would i experience input lag so severely? i have had 2 computers with the same problem, could it be my grounding? i have heard this is a possibility.

Before anyone comments, have you turned off v sync and g sync? yes! Have I turned on 240hz and use a display port? yes!

I have tried multiple mice including the logitech gpro, razer mamba, and model 0 and experience the same problem.

same goes for my keyboards, razer black widow, hyper x alloy fps pro, and ducky one 2 mini.

PROBLEM

You see when i move my mouse wether its on my desktop or in game, Fortnite, CSGO, Minecraft, Overwatch, Call of duty any game! The mouse movement feels like its floating or sluggish like im dragging the cursor slower than normally, Every mice ive has i set it to 1000hz 800dpi, i have mouse acceleration off and set to the 6th tick.

I have tried reinstalling windows 3 times on my new pc! Ive reset the system 2 times as well, Ive called an electrical engineer which he said the volts and wattage coming through my wall is perfectly fine but never checked my grounding system, could that be the issue?? could the electrical current going through my pc be quote on quote “bad”?

could it be my circuitry?

ANOTHER ISSUE!
Another way of explaining it is that when i move the same distance twice from point a to point be it will become shorter or longer never the same, With my new pc it was fine for the forst 4 days it was fixed! then just two days ago it went bad again.

id appreciate any help!! thank you!
 
Aug 16, 2019
1
0
10
0
One thing that helped me was turning off the recording feature in xbox game bar. (Settings > Gaming > Xbox Game Bar) Also be sure to disable the geforce experience “Share” option in the settings and the in game overlay. One more thing is to uninstall your drivers using DDU since it is a true wipe of your drivers and reinstalling them (Click Clean and Restart to uninstall your drivers once you download it). This one didnt help me but you never know what could work.
 

ASK THE COMMUNITY