Internet links in email and docs fail

G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.basics (More info?)

Hi Group,

Any advice please on this problem?
If there are internet links in a Word document then when I do Alt-Click it
fails with an error message. No program known for this application or
somesuch.
Word should fire up IE and pass it the link.

This same problem happened in Outlook (internet links in email messages).
When I clicked on the link, Outlook brought up an error window but allowing
me to browse for the program which was to be run to deal with the link.
I browsed to IEexplore.exe and from there on the problem was fixed in
Outlook.

Now I need to fix it in Word (or generically in XP)

So, somewhere there is a setting in XP that tells what program is to be run
when a
link is clicked in a email/Word.

BUT WHERE?

Ger
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.basics (More info?)

Try this:

Go to Start and type the following in the run box and press enter:

regsvr32 urlmon.dll

Then, open Internet Explorer and go to Tools\Internet Options\Programs and
click 'Reset Web Settings...'. Then try the links again.


--
Michael Solomon MS-MVP
Windows Shell/User
Backup is a PC User's Best Friend
DTS-L.Org: http://www.dts-l.org/

"Ger" <gerdalt999@hotmail.com> wrote in message
news:HKsid.40902$Z14.15719@news.indigo.ie...
> Hi Group,
>
> Any advice please on this problem?
> If there are internet links in a Word document then when I do Alt-Click it
> fails with an error message. No program known for this application or
> somesuch.
> Word should fire up IE and pass it the link.
>
> This same problem happened in Outlook (internet links in email messages).
> When I clicked on the link, Outlook brought up an error window but
> allowing
> me to browse for the program which was to be run to deal with the link.
> I browsed to IEexplore.exe and from there on the problem was fixed in
> Outlook.
>
> Now I need to fix it in Word (or generically in XP)
>
> So, somewhere there is a setting in XP that tells what program is to be
> run when a
> link is clicked in a email/Word.
>
> BUT WHERE?
>
> Ger
>
>
>
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.basics (More info?)

"Ger" <gerdalt999@hotmail.com> wrote in message
news:HKsid.40902$Z14.15719@news.indigo.ie
> Hi Group,
>
> Any advice please on this problem?
> If there are internet links in a Word document then when I do
> Alt-Click it fails with an error message. No program known for this
> application or somesuch.
> Word should fire up IE and pass it the link.
>
> This same problem happened in Outlook (internet links in email
> messages). When I clicked on the link, Outlook brought up an error
> window but allowing me to browse for the program which was to be run
> to deal with the link. I browsed to IEexplore.exe and from there on the
> problem was fixed in
> Outlook.
>
> Now I need to fix it in Word (or generically in XP)
>
> So, somewhere there is a setting in XP that tells what program is to
> be run when a
> link is clicked in a email/Word.
>
> BUT WHERE?
>
> Ger

From http://www.fjsmjs.com/OE/nolinks.htm

Open Windows Explorer.
Go to Tools | Folder Options | File Types.
Scroll down to URL:HyperText Transfer Protocol and select it.
Click Edit or Advanced, depending on your Windows version.
Select 'open'.
Click Edit.

"Application used to perform this action" should read:

"C:\PROGRAM FILES\INTERNET EXPLORER\iexplore.exe" -nohome
(Check the path to iexplore.exe to make sure that is correct and use the
double quotes.)

DDE should be checked and in the boxes below it you should have:

#1:
"%1",,-1,0,,,,
#2
IExplore
#3 (blank)

#4
WWW_OpenURL

URL:HyperText Transfer Protocol with Privacy should be the same.

Sometimes it is necessary to uncheck Use DDE.

If that doesn't fix it, go to Start | Run and type

regsvr32 urlmon.dll

--
Frank Saunders, MS-MVP, IE/OE
Please respond in Newsgroup only. Do not send email
http://www.fjsmjs.com
Protect your PC
http://www.microsoft.com/security/protect/
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.basics (More info?)

"Frank Saunders, MS-MVP" <franksaunders@mvps.org> wrote in message
news:%237CFGirwEHA.2876@TK2MSFTNGP12.phx.gbl...
> "Ger" <gerdalt999@hotmail.com> wrote in message
> news:HKsid.40902$Z14.15719@news.indigo.ie
>> Hi Group,
>>
>> Any advice please on this problem?
>> If there are internet links in a Word document then when I do
>> Alt-Click it fails with an error message. No program known for this
>> application or somesuch.
>> Word should fire up IE and pass it the link.
>>
>> This same problem happened in Outlook (internet links in email
>> messages). When I clicked on the link, Outlook brought up an error
>> window but allowing me to browse for the program which was to be run
>> to deal with the link. I browsed to IEexplore.exe and from there on the
>> problem was fixed in
>> Outlook.
>>
>> Now I need to fix it in Word (or generically in XP)
>>
>> So, somewhere there is a setting in XP that tells what program is to
>> be run when a
>> link is clicked in a email/Word.
>>
>> BUT WHERE?
>>
>> Ger
>
> From http://www.fjsmjs.com/OE/nolinks.htm
>
> Open Windows Explorer.
> Go to Tools | Folder Options | File Types.
> Scroll down to URL:HyperText Transfer Protocol and select it.
> Click Edit or Advanced, depending on your Windows version.
> Select 'open'.
> Click Edit.
>
> "Application used to perform this action" should read:
>
> "C:\PROGRAM FILES\INTERNET EXPLORER\iexplore.exe" -nohome
> (Check the path to iexplore.exe to make sure that is correct and use the
> double quotes.)
>
> DDE should be checked and in the boxes below it you should have:
>
> #1:
> "%1",,-1,0,,,,
> #2
> IExplore
> #3 (blank)
>
> #4
> WWW_OpenURL
>
> URL:HyperText Transfer Protocol with Privacy should be the same.
>
> Sometimes it is necessary to uncheck Use DDE.
>
> If that doesn't fix it, go to Start | Run and type
>
> regsvr32 urlmon.dll
>
> --
> Frank Saunders, MS-MVP, IE/OE
> Please respond in Newsgroup only. Do not send email
> http://www.fjsmjs.com
> Protect your PC
> http://www.microsoft.com/security/protect/
>
>

WOW!! What a Newsgroup. Real quality responses.
Was never an MS fan but this could change things :)
Many, many thanks to Michael and Frank.

Ger
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.basics (More info?)

You're welcome, good luck.

--
Michael Solomon MS-MVP
Windows Shell/User
Backup is a PC User's Best Friend
DTS-L.Org: http://www.dts-l.org/

"Ger" <gerdalt999@hotmail.com> wrote in message
news:KTOid.41002$Z14.15944@news.indigo.ie...
>
> "Frank Saunders, MS-MVP" <franksaunders@mvps.org> wrote in message
> news:%237CFGirwEHA.2876@TK2MSFTNGP12.phx.gbl...
>> "Ger" <gerdalt999@hotmail.com> wrote in message
>> news:HKsid.40902$Z14.15719@news.indigo.ie
>>> Hi Group,
>>>
>>> Any advice please on this problem?
>>> If there are internet links in a Word document then when I do
>>> Alt-Click it fails with an error message. No program known for this
>>> application or somesuch.
>>> Word should fire up IE and pass it the link.
>>>
>>> This same problem happened in Outlook (internet links in email
>>> messages). When I clicked on the link, Outlook brought up an error
>>> window but allowing me to browse for the program which was to be run
>>> to deal with the link. I browsed to IEexplore.exe and from there on the
>>> problem was fixed in
>>> Outlook.
>>>
>>> Now I need to fix it in Word (or generically in XP)
>>>
>>> So, somewhere there is a setting in XP that tells what program is to
>>> be run when a
>>> link is clicked in a email/Word.
>>>
>>> BUT WHERE?
>>>
>>> Ger
>>
>> From http://www.fjsmjs.com/OE/nolinks.htm
>>
>> Open Windows Explorer.
>> Go to Tools | Folder Options | File Types.
>> Scroll down to URL:HyperText Transfer Protocol and select it.
>> Click Edit or Advanced, depending on your Windows version.
>> Select 'open'.
>> Click Edit.
>>
>> "Application used to perform this action" should read:
>>
>> "C:\PROGRAM FILES\INTERNET EXPLORER\iexplore.exe" -nohome
>> (Check the path to iexplore.exe to make sure that is correct and use the
>> double quotes.)
>>
>> DDE should be checked and in the boxes below it you should have:
>>
>> #1:
>> "%1",,-1,0,,,,
>> #2
>> IExplore
>> #3 (blank)
>>
>> #4
>> WWW_OpenURL
>>
>> URL:HyperText Transfer Protocol with Privacy should be the same.
>>
>> Sometimes it is necessary to uncheck Use DDE.
>>
>> If that doesn't fix it, go to Start | Run and type
>>
>> regsvr32 urlmon.dll
>>
>> --
>> Frank Saunders, MS-MVP, IE/OE
>> Please respond in Newsgroup only. Do not send email
>> http://www.fjsmjs.com
>> Protect your PC
>> http://www.microsoft.com/security/protect/
>>
>>
>
> WOW!! What a Newsgroup. Real quality responses.
> Was never an MS fan but this could change things :)
> Many, many thanks to Michael and Frank.
>
> Ger
>