Question Is my motherboard faulty?

Status
Not open for further replies.
Feb 11, 2020
1
0
10
0
Hello everyone. I recently decided to upgrade my PC, ended up building a new one. But now I'm just stuck with something I'm really not able to find a solution of. I've tried everything, nothing works. I'll be really grateful if someone helps me out here.

I'll start with the specs.

CPU: AMD Ryzen 5 3500
GPU: Nvidia Inno 3d GTX1660
Motherboard: Gigabyte B450 DS3H
RAM: Corsair Vengeance 8GB X 2 (16 GB) 3000mhz
SSD: WD Green 240GB
HDD: WD Blue 1 TB

So I asked a friend to assemble it for me since he's in a better position to get the hardware. He assembles it, I bring it home. The Windows is in SSD, Windows 10 (not a legit copy). Next day, BSOD. And then it kept happening over and over until the window stopped working. The first BSOD error is about ntoskrnl.exe. Second is 'Attempted write to read only memory'. Third is about NPFS.sys. I take it back to him, and he replaces the then Cruicial 8GB sticks with the Corsair ones. Windows crashes again. A day later I replaced the SSD. No change, BSOD again. I detached the SSD, got the Windows on HDD. Now this is a genuine Windows 10 (inactivate). It crashes again. So I install the Window again on the SSD. And you guessed it right, BSOD. I kinda hate the word BSOD now. Anyway, when I do a clean install of the Window, it works fine for a couple of hours. Like I'll get the time to download all the graphics drivers, Steam, a couple of games etc, and then out of nowhere that blue screen would come crashing right at me. And when it happens once, it just keeps happening over and over more frequently until Windows just dies. I checked the dump files and the last BSODs were all about NTOSKRL.exe. Only one was about the hal.dll (hardware abstraction layer). At this point I can't even install the Window because I get a BSOD while installing the Windows itself. I'm running the newest BIOS (F50, I guess). I've checked the SSD for bad sectors, came out clean. Checked the RAM with windows memory diagnostic, came out clean. But when I did the memtest86 on both my RAM sticks, they both came with over 10,000 errors. I ran the test on both the sticks on different slots but it still kept showing the error. So, yeah, I'm just stuck with it and there seems no way out of it. Could it be the motherboard's slot that's resulting into the RAM being corrupted? Like a faulty DIMM slot, maybe. Could it be the processor, too? Someone help me, please. What should I do? I don't really have an additional motherboard and I don't wish to insert more RAM sticks into the slot for they might go bad, too. How can I precisely narrow it down to which component is faulty?
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS