Is my TP-LINK faulty or is it something else?

sunny4bd2

Honorable
Aug 20, 2012
4
0
10,510
0
Hi guys
I have a DSL modem connected to My TP-LINK router which shares Internet as follows:

RJ45 with my Samsung SmartTV, and 3 laptops and 5 Android devices ( 4 phones and one Tab) on WIFI

Here is my recent issue:
I use Google DNS on my router, windows 7 home premiums (original) on my computers and Android devices use ICS, Honeycomb and one Gingerbread 2.3.3.

I use Dolphin to access the internet using WIFI on the phones. Google chrome on PCs.
When accessing specific webpages thru WIFI on devices, I get a "request timed out" error on Dolphin and other mobile broweser, other webpages render normal. These webpages open fine on windows 7. Also, these websites open just fine when using mobile networks!!!

I have reset the TP-LINK and the Beetel 220BX DSL router but no luck.

Please help me with a solution. Do i need a new router??
 

eibgrad

Splendid
I'm not absolutely sure, but it may be the user-agent header of http to blame. One of things these websites do is detect what browser you're using with this http header and adjust their returned pages optimized for those environments. But it's possible under some circumstances the website either doesn't know how to handle that user-agent (e.g., Dolphin), or attempts to use something that it believes will work (e.g., Safari) and it just doesn't work right. This is especially true as you stray farther from the usual cadre of browsers (IE, Firefox, Chrome, Safari, etc.), and platforms w/ more limited capabilities.
 

sunny4bd2

Honorable
Aug 20, 2012
4
0
10,510
0
Thank you for your quick reply but changing the user agent and to another browser didnt help. I used the Tab at my friend's place who has a similar network config as mine and voila... all worked!!
Seems like i should buy another router=(
 
Thread starter Similar threads Forum Replies Date
M Networking 2

Similar threads


ASK THE COMMUNITY