Question LAN not working but Wifi works

Oct 6, 2021
4
0
10
0
Hello, I bought yday ASUS XT8 router. My LTE modem is TP-Link MR200 with SIM card. What I tried so far:

  1. factory rest both modem and router
  2. disable NAT on both
  3. different devices and cables, PC, notebook, CAT 5E cable, CAT6 etc... LAN is just dead.. wifi works on all devices good
When I connect ethernet cable to LAN port on my modem.. and then other end to WAN port on ASUS XT8 Wifi works but other LAN ports on XT8 not. (if I connect my cable to WAN port on modem it still works the same)
When I connect modem to LAN port on ASUS XT8 then Wifi stops working buuut LAN ports work and I have stable wired connection on my PC

Is there some problem between WAN/LAN ports communication or some setting are messed up? Thanks
 
from that picture, u can go with wireless router, thats internet over lan + nat on lan and wifi
thats default profile...so just DHCP would need to be setup
try fixed ip on lan for modem and XT8 with dhcp for devices
x.x.x.0 modem
x.x.x.1 XT8
x.x.x.2-255 for DHCP range
replace x with any number u like
keep just one DHCP server running...doesnt matter if on modem or router...not on both, but preferably on XT8..coz of wifi
you also need to have NAT enabled on XT8...on modem you wont need NAT if you have connected only router to it
 
Last edited:
Your problem is the mr200 is actually a router and it uses the lan IP range as the asus router. When you hook the wan port of the asus to the tplink you have the same IP range on wan and lan.

So your first option is to find a way to make the mr200 a actual modem and then things will work.
Next you can change the IP range on either of the devices so they are not duplicated.

You can also set the asus to run in AP mode but I am unsure what impact that would have on the mesh stuff, if you only have a single node then it will be fine.
Note you must change the IP on the asus to something else even if you run in AP mode. The tplink has 192.168.1.1 so change the asus to 192.168.1.250 or something similar.

A comment on the previous post you can not assign x.x.x.0 to a end device using a common subnet mask. In addition if consumer routers are really stupid they DHCP must be on the actual internet router not on another device. Unlike a server doing dhcp the router will always give the end client its lan ip rather than the actual gateway ip.
 
Oct 6, 2021
4
0
10
0
Thank you for the help. So 1st step is to setup MR200 as modem. I found it could be done by enabling static routing: https://www.tp-link.com/cz/support/faq/1660/
am I correct? If yes then there I must setup destination IP (which on eI should use? my public IP?) then subnet mask (255.255.255.255 is okay?) then gateway should be same as WAN IP on my ASUS XT8? So as I see it in my XT8 admin interface that WAN IP is 192.168.1.100?
Thank you.
 
Nope you are not placing it in bridge mode it is still a router. From what I can have seen other people say there is no way to place the mr200 into bridge mode.

Why don't you just change the lan IP on the asus router to 192.168.2.1. It will then work hooking the asus wan port to the mr200 lan port.
 
Oct 6, 2021
4
0
10
0
I brought is to my job and hook it there (no LTE modem, only classic mikrotik modem and cable provider, we have there Google Wifi pucks and all works correctly on LAN too) problem on XT8 still persist even after factory reset... So I called ASUS support and guy told me I should return it becasue there must be some WAN/LAN communication problem..
Thanks for the valuable help guys!!

I decided to buy cheaper non mesh ASUS TUF AX5400, reason for making upgrade from that crappy MR200 Wifi range/speed was only beacuse of Oculus Air Link.
Thx again!
 

ASK THE COMMUNITY

TRENDING THREADS