[SOLVED] LEDs turning on but no signal on monitor??

Status
Not open for further replies.
Jul 28, 2019
76
3
45
1
I just built a new PC and the fans turn on, leds turn on but nothing comes up on the monitor.. I have the b450 gaming plus, ryzen 5 3600x (yes I flashed my mobo) crucial m.2 ssd, rx5700, and g.skill 2x8 ram, all help is appreciated! Thanks
 
Jul 28, 2019
76
3
45
1
Update: I switched my ran to slots 1 and 3, now no lights are coming up on the EZ debug leds but also nothing on monitor?? Monitor is Not broken
 

Solidjake

Proper
Sep 6, 2019
154
27
140
16
Maybe not related to your issue but you need to secure that nvme drive on the motherboard.... it might not be making contact with the pins hence the system not working correctly.
 
Reactions: harley27
Jul 28, 2019
76
3
45
1
Yes that is normal. Did the system start up fine or same issue? All power cables plugged in? (power cable to the motherboard if it requires it)
IT was the the same as before.. I even tried plugging it in to my tv and changed the cable.. there are a few pins on the bottom that are vacant, I’ll send some pictures
 
Jul 28, 2019
76
3
45
1
That's fine, they're just pins for the header and usb ports on the case itself. Do you have a power cable plugged into the 4x2 (8pin) plug up top to the left of #7?

Could it be the gpu? It has a 8 pin then a 6 pin.. my psu only came with 6+2 pins though so 2 of the pins aren’t in anything
 
Can't see in that video.
What case do you have?
Most require standoffs to be installed.
Some have raised bumps in some places but require a few to be installed. Depending on motherboard size.
There are hundreds of solder points on the back of the motherboard. it only take one touching to cause a no boot or worse fries the motherboard if you have a cheap power supply.
Stand offs are a most
 
Jul 28, 2019
76
3
45
1
Can't see in that video.
What case do you have?
Most require standoffs to be installed.
Some have raised bumps in some places but require a few to be installed. Depending on motherboard size.
There are hundreds of solder points on the back of the motherboard. it only take one touching to cause a no boot or worse fries the motherboard if you have a cheap power supply.
Stand offs are a most
I have the Corsair spec-delta carbide series and Corsair TX 650W psu
 
Jul 28, 2019
76
3
45
1
Power supply is great but case needs standoffs installed.
You should have a small box with screws ,wire ties, stand offs etc.... somewhere that came with it.
https://www.corsair.com/medias/sys_master/images/images/h82/h8a/9149281402910/-CC-9011166-WW-Gallery-SPEC-DELTA-07.png
in this photo you have the motherboard tray with instructions where to install standoffs for different size motherboards.
Each hole is marked with A/M/I or a combination .
You need a standoff in all holes marked "A"
YEs I did that when installing the motherboard
 

Solidjake

Proper
Sep 6, 2019
154
27
140
16
Could it be the gpu? It has a 8 pin then a 6 pin.. my psu only came with 6+2 pins though so 2 of the pins aren’t in anything
I think that's it (but wait for others to reply first before adding another cable)..... you have one (technically) ONE power cable going to the GPU whereas you need two separate cables going into it for full power
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS