Question M.2 boot drive, crashes then restarts in EFI Shell - help needed

Ollington

Honorable
Sep 1, 2014
3
0
10,510
0
So I recently purchased a Sabrent Rocket 4.0 1TB M.2 SSD to replace my boot drive.

I cloned my previous boot drive onto it, and it was working very well. Over the past couple of days I have run into an issue:

- When I close many windows sequentially, they all stop responding, then my PC seizes and powers itself off, I then turn it back on, it loses the drive and boots into EFI shell. I reboot again, and my PC works as normal again, detects the drive and boots into windows as usual.

My specs are:
CPU:
i5-4690K @ 4.2GHz
Motherboard: MSI Gaming 5 Z97
RAM: 4x4GB sticks of Corsair XSM3 1600MHz DDR3 (OC@1800MHz)
GPU: PowerColor Red Dragon RX 5700 XT (stock)
Boot Drive: 1x Sabrent Rocket 4.0 1TB M.2
Secondary Drive: 1x Samsung 850 EVO 500GB SSD
Tertiary Drive: 1x Western Digital Blue 1TB 5200rpm
PSU: Corsair GS700 PSU
Windows Build: Windows 10 Pro 20H2 19042.746

Any help/thoughts would be greatly appreciated, as I am really frustrated with the idea I might have to exchange this drive for another and repeat the cloning process...

If you need any more information let me know.

Thanks!
 
So I recently purchased a Sabrent Rocket 4.0 1TB M.2 SSD to replace my boot drive.

I cloned my previous boot drive onto it, and it was working very well. Over the past couple of days I have run into an issue:

- When I close many windows sequentially, they all stop responding, then my PC seizes and powers itself off, I then turn it back on, it loses the drive and boots into EFI shell. I reboot again, and my PC works as normal again, detects the drive and boots into windows as usual.

My specs are:
CPU:
i5-4690K @ 4.2GHz
Motherboard: MSI Gaming 5 Z97
RAM: 4x4GB sticks of Corsair XSM3 1600MHz DDR3 (OC@1800MHz)
GPU: PowerColor Red Dragon RX 5700 XT (stock)
Boot Drive: 1x Sabrent Rocket 4.0 1TB M.2
Secondary Drive: 1x Samsung 850 EVO 500GB SSD
Tertiary Drive: 1x Western Digital Blue 1TB 5200rpm
PSU: Corsair GS700 PSU
Windows Build: Windows 10 Pro 20H2 19042.746

Any help/thoughts would be greatly appreciated, as I am really frustrated with the idea I might have to exchange this drive for another and repeat the cloning process...

If you need any more information let me know.

Thanks!
Guess..................bios/chipset driver/management engine driver.
 

ASK THE COMMUNITY