Question M.2 NVMe Not recognized by Disk Manager (SOLVED)

Oct 15, 2020
5
0
10
0
Just bought a 970 EVO Plus 1TB m.2 drive. Disk management shows no unallocated drives. It shows up in BIOS, Device manager and Windows Storage Spaces, However it isn't recognized at all by Disk Manager.

I've refreshed and scanned disks in disk management, still nothing showing up. Flashed BIOS and updated it, Samsung NVMe Driver installed. SATA is in AHCI.

Specific MOBO info- https://dlcdnets.asus.com/pub/ASUS/mb/LGA1151/PRIME_Z370-A/E13271_PRIME_Z370-A_UM_WEB.pdf the M.2 drive in question is in m.2_2 (above GPU) set up in BIOS as x4 mode, which I understand disables SATA6G_56. Neither of the other 2 HDDs are plugged into those ports.
I initially had it in the m.2_1 slot under the heat spreader with the same results, so I am at a loss.

I have looked through other threads with similar issues to no avail, so appreciate any help I can get, thank you all in advance


EDIT: SOLVED- thank you all for your quick responses
 
Last edited:

Turtle Rig

Prominent
BANNED
Jun 23, 2020
772
103
590
23
Can you see the m.2 in the BIOS ? If so I think we can sort this out for you. Also you might need a BIOS firmware upgrade just FYI my friend.✝👶🙈🎗
 

ASK THE COMMUNITY

TRENDING THREADS