Question Monitor Shows No Display Upon Installing New CPU

Dec 3, 2019
3
0
10
0
So almost a week ago I ordered the Ryzen 3700x after upgrading from a Ryzen 3 (1200) and so I switched out the old one to put in the 3700x and when I tried starting my computer, it said that the monitor was in power save mode...

Relevant Info:
Mobo: ASRock A320M-HDV R4.0 Micro ATX AM4 Motherboard
GPU: Gigabyte 1050 ti
Power supply is capable of 600 watts idk what my ps is

Since I couldn’t put the old cpu back in and see if it worked due to bent pins, I ordered another cpu (AMD Athlon 200GE 2‑Core 4‑Thread AM4 Socket) compatible with my Mobo that didn’t require a flash bios or an updated bios as I thought that was the issue but it still didn’t work so I’m kinda confused, it is probably a simple fix that’s why I’m holding back on taking it to getting it token to a shop.

kinda a pc noob help plz :(
 
can you carefully try straightening the pins on the old CPU? (Nothing to lose, as long as you still have it....even if a pin breaks, it might be unused, or redundant power in, or affect just one RAM channel, and might still be usable for at least the BIOS flash, post pin-repair, etc...
 
Dec 3, 2019
3
0
10
0
can you carefully try straightening the pins on the old CPU? (Nothing to lose, as long as you still have it....even if a pin breaks, it might be unused, or redundant power in, or affect just one RAM channel, and might still be usable for at least the BIOS flash, post pin-repair, etc...
Yea I already tried, I actually even called a couple of shops to ask if the cpu bent pins were repairable they said it’s near impossible and insanely hard.
 

ASK THE COMMUNITY

TRENDING THREADS