thevillieater

Honorable
Jul 29, 2015
47
0
10,530
0
Hi All,
Over the past few weeks I built a new PC and I am having trouble with my wireless mice (Logitech MX Master 3,MX Performance, MX vertical.).

The problem: Its as if there is a spot on the mousepad where the mouse gets stuck and stutters. When I lift the mouse up and place it back down, the spot changes. When i am dragging something with my mouse (holding down left click) it lets it go (somehow disconnects). The issue gets worse with gaming but also happens when i'm doing light work on windows.


I have 5 different wireless Mice and I have tested all have the same problem (Two are brand new).
I have tried 2 mousepads and no mousepad, same problem.
I have tried all of my usb ports 3.0 and 2.0
Reinstalled all my drivers + chipset + bios

I have a pair of wireless USB headphones and they work properly.
I have a USB bluetooth dongle and this doesn't work properly. It has trouble connecting from time to time. When I use the windows default bluetooth drivers, it works semi-consistently. (I connect my keyboard to it)

I don't know what else to do and I am so tired of it.

Further information:
Ryzen 5 3600x
RX 5700xt
MSI B450 PRO VDH MAX
NZXT H510

My final thoughts are that I think it has to be some kind of faulty motherboard because it did come with a bent fan pin but I don't know. Any advice or help is appreciated :) .
 
Oct 7, 2020
4
0
10
0
Ayo, I had the same problem too except in my case I ran on a Laptop. Hopefully, this helps though.

Open Human Imaging and find your peripheral (check mouse and pointer). After you opened the dropdown and are able to see all the devices right-click on your mouse or whatever, and click properties, on the top tab click on power management and make sure allow the computer to turn this device off to save power is checked off.
Now your mouse may show up here, (mouse and other pointers) but check all of the drop-downs to make sure your mouse isn't listed over there. For example, my Razer Viper Ultimate was listed in Mouse and other pointers, keyboards, and human interfacing devices.

If that doesn't help try this.

So in your bios settings try to find c - state. And disable this, idk why but some motherboards (like mine) have it enabled to save power and such.
If you don't find it just search for a tutorial to make sure it is even there.

Ight lets say no luck your motherboard manufacturer just doesn't have this option. Install Quick - CPU. When first launching click you are greeted onto a page where you can see all of your data. On the top of the window (under the x) find Advanced CPU Settings. It now has/should have opened a new window. On the left side under the sub-heading General find C1E and uncheck the box. Click apply on the bottom, apply again when back on the home page, then minimize (Don't x it out).

I hope this helps, it worked for me when I had unbearable latency on my laptop.

Quick Tutorial: No sound: https://www.loom.com/share/b4a03c1ebe25485db586b62d8a9884d2
 
Dec 14, 2020
4
0
10
0
Hi,

I have the exact same problem. I bought an MX Master 3 and it was working fine for awhile on both my PC and Mac. However, a couple of weeks ago it suddenly started doing the lag/jump thing when I lift it and put it back down, but this only happens on my PC (which is a super-powerful beast I recently built).

I contacted Logitech and they sent me a new one but it has the same problem.

I've tried changing the power-saving settings as mentioned by Ashi360 here, and as I saw suggested in other forums, but no luck.

What's really annoying is that my cheap Logitech M325 does not have this problem. So it's something unique to the MX Master 3 and Windows 10.

If anyone has any other solutions please let me know because I can't even return the mouse at this point since it's past the return date.

Thanks
 
Dec 14, 2020
4
0
10
0
Ashi360,

Thanks for the reply. Yes, I have the software installed.

I tried the raw input thing and it seemed to solve the problem . . . for about a minute, then it came right back. The problem is that it comes and goes. It will be fine for a few minutes, then it was suddenly start up again.
 
I recently has such an issue with my mx master 3.
It turns out that I had the mouse usb dongle plugged into one of the front usb3.0 ports at the same time I was using the companion port very heavily to upload a photo folder to a high speed usb device.
 

ASK THE COMMUNITY

TRENDING THREADS