[SOLVED] My aorus b450 is not working

Jul 11, 2021
8
1
15
0
I have a auros b450 elite and I cant seem to get any power. Its a brand new pc and the specs are a ryzen 7 3600, 1660 ti, 650 watt gold psu and a 2x8gb sticks of hyper x predator ram. When I try turn on the pc I get no response. When I flick the switch off on the psu a red light flashes on the mother board. Ive tried unplugging everything and then putting it all back in and that did not work. I tried putting 1 stick of ram in that didnt work. I tried jump starting that didn't work. I really need help.
 

kurdtnz

Estimable
i would not know i through out the box
Many of the later B450 boards support ryzen 3000 straight from the box but many also dont so you may need to update the BIOS to support your 3600. Unfortunately I dont think your motherboard has BIOS Flash so you will need a 2000 series cpu in order to update it to be 3000 series compatible. (does your motherboard have a small sticker on it somewhere which says what BIOS version it has?)
 
Jul 11, 2021
8
1
15
0
Many of the later B450 boards support ryzen 3000 straight from the box but many also dont so you may need to update the BIOS to support your 3600. Unfortunately I dont think your motherboard has BIOS Flash so you will need a 2000 series cpu in order to update it to be 3000 series compatible. (does your motherboard have a small sticker on it somewhere which says what BIOS version it has?)
ill check now
 
Jul 11, 2021
8
1
15
0
No,that is not the BIOS version but the chipset socket. My best guess is that you do not have the correct BIOS to run a 3000 series cpu and it needs updating. Unless you have a 2000 series cpu and if you dont know how to update, do you have a local PC shop near you that could do it for you?
the motherboard is frequentley flashing green and the gpu just turning on for a second.
 

ASK THE COMMUNITY

TRENDING THREADS