[SOLVED] My keyboard outputs multiple keys with one key press, with a twist...

JayTee3

Reputable
May 9, 2017
143
2
4,695
1
So basically to rant it out I would say:

  • So like on my normal keyboard colour setting (Profile 1 or P1) I press A once and i get AAAAAAAAAAAAAAAAAAAAA.When previously it was fine, making it impossible to type, e.g. if I typed apple it would literally, be this as I test it aaaappppppppllllllllllllllllllleeeeeeeeeeeeeeeeeeeeeee.
  • On my second setting (P2) its kinda normal but if i do anymore than just quickly press a key i get aaaaaaaa or backspacing is the worst i lose like everything if i just wanna backspace one word it backspaces everything.
  • The only thing I can see online is that its like liquid damage but I don't understand how i could of got liquid on it and also why the severity of the bug is different on the colour profiles (pressing p1,p2 etc)
  • I just tried to use p3 and p4, and they work fine as I haven't set up any colour profiles and I can type normally (how I made this thread) but.. it still doesn't explain anything at all, why was it working perfectly on my default setting then just randomly went weird, and if its hardware related (like all the threads about this issue happening to laptops or keyboards) then why do the other profiles work fine?
 

JayTee3

Reputable
May 9, 2017
143
2
4,695
1
Update: Fixed. Thankyou to Hang-the-9 for encouraging me to search the model and see if it has this issue with other people

https://www.reddit.com/r/coolermaster/comments/58cfe3 View: https://www.reddit.com/r/coolermaster/comments/58cfe3/masterkeys_pro_s_masterkeys_pro_l_pressing_keys/


Credit to this user

Fix was:

"To fix it, simply hold FN and hit F5. This should change your repeat rate back to 1x. If you accidentally changed it on different profiles, just hit FN+1/2/3/4 and go through on those profiles and change it too."

I'm not sure how I got it on P2 as well since I never use it, but there you go :)
 

hang-the-9

Titan
Moderator
Without knowing what model/brand or what you tried already no way to know what the issue may be. If this is happening only with color settings, sounds like the software or the firmware on the keyboard is messing up but the key is physically fine. Contact the keyboard vendor, check their support site for any issues like this that were reported. If there is a hard reset on the keyboard try that.
 

JayTee3

Reputable
May 9, 2017
143
2
4,695
1
Without knowing what model/brand or what you tried already no way to know what the issue may be. If this is happening only with color settings, sounds like the software or the firmware on the keyboard is messing up but the key is physically fine. Contact the keyboard vendor, check their support site for any issues like this that were reported. If there is a hard reset on the keyboard try that.
Sorry that was a bit silly to not include it sorry

It is a Coolermaster Masterkeys Pro Keys L (RGB, Brown Switches) . I will contact CM too
 

JayTee3

Reputable
May 9, 2017
143
2
4,695
1
Update: Fixed. Thankyou to Hang-the-9 for encouraging me to search the model and see if it has this issue with other people

https://www.reddit.com/r/coolermaster/comments/58cfe3 View: https://www.reddit.com/r/coolermaster/comments/58cfe3/masterkeys_pro_s_masterkeys_pro_l_pressing_keys/


Credit to this user

Fix was:

"To fix it, simply hold FN and hit F5. This should change your repeat rate back to 1x. If you accidentally changed it on different profiles, just hit FN+1/2/3/4 and go through on those profiles and change it too."

I'm not sure how I got it on P2 as well since I never use it, but there you go :)
 

ASK THE COMMUNITY

TRENDING THREADS