Feb 26, 2010
Hey guys,

Sorry if this is in the wrong category, but it's unclear if it's a mouse/motherboard/plug n play issue I have here.

So simply, I can't click with my mouse...most of the time.
I can scroll, move around and it lights up.

This problem started a few days ago. I assumed it was a driver issue or maybe some buildup in the mouse.
Unfortunately I have spent the last few days realizing it's some mystery issue that I can't tackle.

So far I have tried :
Different Mice
Different USB Ports
Re-installing/changing drivers
Changing Operating Systems (Vista 64bit to W7 64bit)
Extensively cleaning and checking connections on the inside of my computer incase of cable creak or dust build up causing general unstability.

I'm stumped.

My current specs :
Windows 7 64bit
CPU : Athlon X2 Dual Core 6400+
Motherboard : Crossfire
4GB of DDR2 ram.
8800 GTS 512mb

My current mouse is 2 months old, the Razer Imperator but I'm confident it is not the mouse or the port.

I found 1 post on some random forum that talked about a similar issue where the only solution was de-activating Plug n Play. Not really a solution considering I run everything off USB.

So...any bright ideas or questions?


Jan 29, 2010
do you have any ps2 ports on your motherboard? buy an adapter that converts usb to ps2 and try it that way.... does this happen randomly or just after the computer wakes up from sleep mode? do you have to manually set the mouse buttons?