Question New Build Problem

Feb 26, 2020
2
0
10
0
Put a new build together, everything worked fine for a few days. Today I added a CD drive and a fan. When I plugged power cord back in and flipped power switch on back of the case, my PSU fan started up then immediately stopped and the light on the front case power button lights up and stays on (without having pressed it). There was also a burning smell (great!). I immediately turned off power/unplugged the CD drive and fan I added, but still same issue. As soon as power switch on back of case is flipped, PSU fan turns on and then immediately off. Power button on front of case stays on but pressing it doesn’t do anything. Can’t even get to BIOS. I’m assuming motherboard is fried? What should I troubleshoot first before I buy new parts. Please help! :(
 
Sounds like something got fried, and since it happened when you added the CD drive/fan that was the cause. Trace back to all the connections the CD drive and fan made and look for damage, it will be unmistakable on a motherboard.

Now it could very well be the PSU as well, if that's the case then it should haven't damaged the rest of the computer. What PSU is in the computer?
 
Feb 26, 2020
2
0
10
0
Sounds like something got fried, and since it happened when you added the CD drive/fan that was the cause. Trace back to all the connections the CD drive and fan made and look for damage, it will be unmistakable on a motherboard.

Now it could very well be the PSU as well, if that's the case then it should haven't damaged the rest of the computer. What PSU is in the computer?
Yeah I took out the two items I added. Didn’t notice damage, but will look again. The PSU is a Corsair RM 550x. I swapped in a PSU from an older build and had slightly similar result. Once power switch on the back gets switched the PSU/CPU/graphics cards all turn on full blast and stay on and power button on front lights up without being touched (pressing it doesn’t do anything)
 

ASK THE COMMUNITY

TRENDING THREADS