Question No Display After Enabling Secure Boot on Win10

Oct 16, 2021
8
2
10
0
I wanted to get win 11 so I ran the pc health check and followed steps to enable tpm 2.0. I did that and got an update for win 11 without enabling secure boot. However, when I tried playing valorant I got an error that said the secure boot was needed so I looked up how to enable that.
My mobo is gigabyte b550m aorus elite. I went to the BIOS and disabled CSM and exited and rebooted my pc. Then again to the bios and enabled secure boot. This is where it goes bad. My system seemed like it booted but I had no display. I did everything from changing displays to cables, nothing worked. I have Ryzen 5 3600 which requires a dedicated GPU if I am not wrong. Lastly, I removed the CMOS and reset the bios. I reverted back to Windows 10 and followed the same procedure, but again the same results. And by drives are already GPT and Windows shows bios as UEFI. GPU is 1660 super.
What am I missing? Please help.
 
Oct 16, 2021
8
2
10
0
Open up an administrative command prompt.
Type 'diskpart' and hit enter.
Type 'list disk' and hit enter.
Post the output you get.
Type exit to exit diskpart.
Here are the results

Microsoft Windows [Version 10.0.19043.1288]
(c) Microsoft Corporation. All rights reserved.

C:\WINDOWS\system32>diskpart

Microsoft DiskPart version 10.0.19041.964

Copyright (C) Microsoft Corporation.
On computer: DESKTOP-P5FTFJU

DISKPART> list disk

Disk ### Status Size Free Dyn Gpt
-------- ------------- ------- ------- --- ---
Disk 0 Online 1863 GB 1024 KB *
Disk 1 Online 953 GB 515 MB *
Disk 2 Online 14 GB 0 B

DISKPART> exit

Leaving DiskPart...

C:\WINDOWS\system32>
 
Oct 28, 2021
5
0
10
0
I wanted to get win 11 so I ran the pc health check and followed steps to enable tpm 2.0. I did that and got an update for win 11 without enabling secure boot. However, when I tried playing valorant I got an error that said the secure boot was needed so I looked up how to enable that.
My mobo is gigabyte b550m aorus elite. I went to the BIOS and disabled CSM and exited and rebooted my pc. Then again to the bios and enabled secure boot. This is where it goes bad. My system seemed like it booted but I had no display. I did everything from changing displays to cables, nothing worked. I have Ryzen 5 3600 which requires a dedicated GPU if I am not wrong. Lastly, I removed the CMOS and reset the bios. I reverted back to Windows 10 and followed the same procedure, but again the same results. And by drives are already GPT and Windows shows bios as UEFI. GPU is 1660 super.
What am I missing? Please help.
I had the same problem, interestingly the solution is not what you might think! Your drive needs to be converted from MBR to GPT and that will fix all of your problems to satisfy things for Windows 11. You actually don't need to enable secure boot in the BIOS. It has to do with UEFI not working the same with MBR. After you update from MBR to GPT all will be well and you can leave the CSM Support Enabled in your BIOS, with UEFI (Not legacy selected). You also need to have the trusted platform enabled in your BIOS to satisfy the TPM 2.0 requirement. For those who "Break" their BIOS by enabling secure boot on a Gigabyte motherboard I temporarily had that problem but was able to hold down the power and reset buttons together for several seconds to reset or get to the backup BIOS with the CSM Support Enabled back on! There are probably a couple ways to convert your drive from MBR to GPT, just google it and you'll find many options! I did the one through the control panel recovery and then command prompt option. You can see if your drive is MBR in the windows partition tool, right click on drive and click on volumes and it will tell you the formatting type. Good luck!!!
 
Nov 17, 2021
2
1
15
0
I had the same problem, interestingly the solution is not what you might think! Your drive needs to be converted from MBR to GPT and that will fix all of your problems to satisfy things for Windows 11. You actually don't need to enable secure boot in the BIOS. It has to do with UEFI not working the same with MBR. After you update from MBR to GPT all will be well and you can leave the CSM Support Enabled in your BIOS, with UEFI (Not legacy selected). You also need to have the trusted platform enabled in your BIOS to satisfy the TPM 2.0 requirement. For those who "Break" their BIOS by enabling secure boot on a Gigabyte motherboard I temporarily had that problem but was able to hold down the power and reset buttons together for several seconds to reset or get to the backup BIOS with the CSM Support Enabled back on! There are probably a couple ways to convert your drive from MBR to GPT, just google it and you'll find many options! I did the one through the control panel recovery and then command prompt option. You can see if your drive is MBR in the windows partition tool, right click on drive and click on volumes and it will tell you the formatting type. Good luck!!!
I have this problem too but my drives are already GPT are there any other solutions?
 
Reactions: lekeim
Nov 17, 2021
2
1
15
0
I wanted to get win 11 so I ran the pc health check and followed steps to enable tpm 2.0. I did that and got an update for win 11 without enabling secure boot. However, when I tried playing valorant I got an error that said the secure boot was needed so I looked up how to enable that.
My mobo is gigabyte b550m aorus elite. I went to the BIOS and disabled CSM and exited and rebooted my pc. Then again to the bios and enabled secure boot. This is where it goes bad. My system seemed like it booted but I had no display. I did everything from changing displays to cables, nothing worked. I have Ryzen 5 3600 which requires a dedicated GPU if I am not wrong. Lastly, I removed the CMOS and reset the bios. I reverted back to Windows 10 and followed the same procedure, but again the same results. And by drives are already GPT and Windows shows bios as UEFI. GPU is 1660 super.
What am I missing? Please help.
I had this exact problem and I fixed it yesterday. You need to update your bios to the latest version, I used q-flash to do this inside my bios. After updating your bios turn csm support off restart then turn on secure boot, if secure boot is already on then turn it off restart and turn it back on again, if it doesn't let you then select something that sounds like something along the lines of "Reset factory keys" then turn on secure boot and it should be working. I hope this helps!
 
Dec 9, 2021
2
0
10
0
I had this exact problem and I fixed it yesterday. You need to update your bios to the latest version, I used q-flash to do this inside my bios. After updating your bios turn csm support off restart then turn on secure boot, if secure boot is already on then turn it off restart and turn it back on again, if it doesn't let you then select something that sounds like something along the lines of "Reset factory keys" then turn on secure boot and it should be working. I hope this helps!
I'm having the same problem as OP. My drives are also already GPT. The main problem I'm having is that after I turn on secure boot, my PC is no longer registering my mouse's device signature. I can't do much without the mouse.
 
Dec 9, 2021
2
0
10
0
I had the same problem, interestingly the solution is not what you might think! Your drive needs to be converted from MBR to GPT and that will fix all of your problems to satisfy things for Windows 11. You actually don't need to enable secure boot in the BIOS. It has to do with UEFI not working the same with MBR. After you update from MBR to GPT all will be well and you can leave the CSM Support Enabled in your BIOS, with UEFI (Not legacy selected). You also need to have the trusted platform enabled in your BIOS to satisfy the TPM 2.0 requirement. For those who "Break" their BIOS by enabling secure boot on a Gigabyte motherboard I temporarily had that problem but was able to hold down the power and reset buttons together for several seconds to reset or get to the backup BIOS with the CSM Support Enabled back on! There are probably a couple ways to convert your drive from MBR to GPT, just google it and you'll find many options! I did the one through the control panel recovery and then command prompt option. You can see if your drive is MBR in the windows partition tool, right click on drive and click on volumes and it will tell you the formatting type. Good luck!!!
OP said their drives are already on GPT, same as mine. I'm having the exact same errors. Going into BIOS and enabling secure boot works. However, my PC doesn't recognize my mouse's device signature.
 

ASK THE COMMUNITY

TRENDING THREADS