• Our team is working to address issues posting quotes or media to the forums. Please bear with us as we get this sorted out.

Question No display after installing new graphics card

Jul 25, 2021
2
0
10
0
I'm getting black screen after installing new 3080ti graphics card
Please find my pc specifications below,
Motherboard : Asus rog strix b360f gaming
CPU : i5 8600k
Ram : 20GB Hyperx 2133
Old GPU : MSI 1060
New GPU : Zotac 3080ti
PSU : cooler master 850W

I have tried updating bios and uninstalling nvidia drivers while connecting to motherboard(on board Intel HD graphics)
 
Jul 26, 2021
7
0
10
0
hmmmmm does it have a 6 pin connector or 8 pin look closly? if it does you will ethier need to get a adapter or a power supply with a 6 pin or 8 pin. And the reason if it does have a 6 pin or 8 pin power connector is because the thing needs more power which is why it needs a connector? thats really my only suggestion it could be something else but maybe this will help!
 

hutchl

Distinguished
Apr 3, 2014
289
34
18,840
13
When uninstalling the old driver did you boot to safe mode and use DDU? Make sure the card is correctly seated in the slot. Make sure you don’t have a cable problem, try using different ports on the on the GPU to connect your monitor. PSU may be having issues.
 
Jul 25, 2021
2
0
10
0
Even after putting new GPU in new system still there was no display so I have returned the graphics card. Thank you for the help.
 

tecmo34

Administrator
Moderator
FYI... 3080 Ti has a know issue that it will show just a black screen until Windows loads, no BIOS screen with Display Port. It isn't an issue with HDMI, just Display Port. EVGA has rolled out a BIOS update that has fixed the issue for their cards, though can't speak for others. This could have been your issue if you didn't wait long enough for Windows to boot to the screen, since didn't show the BIOS screen.
 

ASK THE COMMUNITY