• Our team is working to address issues posting quotes or media to the forums. Please bear with us as we get this sorted out.

Question No display signal on fresh built PC despite turning on!

Jul 21, 2021
3
0
10
0
So I’ve finally saved up for my newest PC upgrade (parts listed below). I’ve slapped it all together and the system happily turns on, fans, lights etc, however, I can’t get any video output on my tv it’s connected to?
I’ve tried several HDMI cables, detached and reattached ram and more after reading troubleshooting posts all day.

I can’t for the life of me figure out the problem, I was hoping you kind people could help me figure this out!

Specs:
Motherboard: MSI MAG 550b tomahawk
RAM: Corsair vengeance RGB SL PRO (3600mhz), (2x8Gb)
GPU: Powercolor AMD Radeon RX 6700 XT Red Devil Graphics Card
CPU: AMD Ryzen 7 5800X 8 Core CPU
PSU: Corsair RM850 80plus gold

SSD: Crucial MX500 1TB 2.5” SATA
CPU FAN: Arctic Freezer Xtreme R2

(Apologies if the format isn’t standard, this is my first post!)

Many thanks!
- Matty
 
Jul 21, 2021
3
0
10
0
Yes! I’ve tried both hdmi and hdmi to display port cables (several different ones). All were plugged into the GPU first and I attempted the mobo aswell. I’ve also swapped the GPU out for my old GTX 960 and the same problem has occurred, I may try to add the 960 to a different pcie aswell!
 

Zerk2012

Titan
Ambassador
So I’ve finally saved up for my newest PC upgrade (parts listed below). I’ve slapped it all together and the system happily turns on, fans, lights etc, however, I can’t get any video output on my tv it’s connected to?
I’ve tried several HDMI cables, detached and reattached ram and more after reading troubleshooting posts all day.

I can’t for the life of me figure out the problem, I was hoping you kind people could help me figure this out!

Specs:
Motherboard: MSI MAG 550b tomahawk
RAM: Corsair vengeance RGB SL PRO (3600mhz), (2x8Gb)
GPU: Powercolor AMD Radeon RX 6700 XT Red Devil Graphics Card
CPU: AMD Ryzen 7 5800X 8 Core CPU
PSU: Corsair RM850 80plus gold

SSD: Crucial MX500 1TB 2.5” SATA
CPU FAN: Arctic Freezer Xtreme R2

(Apologies if the format isn’t standard, this is my first post!)

Many thanks!
- Matty
The board requires at least the A4 BIOS version for the processor updating the BIOS is a good place to start.

https://www.msi.com/Motherboard/support/MAG-B550-TOMAHAWK#support-cpu
 
Jul 21, 2021
3
0
10
0
I’m actually currently in the middle of updating the BIOS, it was my last resort as I was worried about screwing it up haha!
 

ASK THE COMMUNITY