Question Not posting with dual RAM

Aug 15, 2020
6
0
10
0
My PC is still new built with Ryzen 5 3600x 2 16Gb DDR 4 RAM and when I first used it, it worked fine. However, ever since i done an update it stopped posting. I realised it was my RAM and so I investigated. The PC posts with 1 RAM but if i put the second it doesn't post anymore. It's not the RAM because I've tested both and individually the work fine on all slots, so it's not the slots either. I don't understand because it was working fine before the update. Both RAMs are identical 16Gb. Have an ASUS Prime B450-Plus MotherBoard.

Would appreciate any help.
 

egda23

Upstanding
Jun 14, 2020
428
76
290
15
My PC is still new built with Ryzen 5 3600x 2 16Gb DDR 4 RAM and when I first used it, it worked fine. However, ever since i done an update it stopped posting. I realised it was my RAM and so I investigated. The PC posts with 1 RAM but if i put the second it doesn't post anymore. It's not the RAM because I've tested both and individually the work fine on all slots, so it's not the slots either. I don't understand because it was working fine before the update. Both RAMs are identical 16Gb. Have an ASUS Prime B450-Plus MotherBoard.

Would appreciate any help.
What update ? Bios , Win 10 ?
Exact reference of your RAM ?
16 Gb total or 2 x 16 GB ?
PSU ?
 
Aug 15, 2020
6
0
10
0
What update ? Bios , Win 10 ?
Exact reference of your RAM ?
16 Gb total or 2 x 16 GB ?
PSU ?
Not sure what the update was for it was one of those update and shut down ones. I'm on Windows 10. My BIOS is American Megatrends Inc version 3.1. It's 2 X 16GB making 32GB. PSU is a CORSAIR 550W CV SERIES™ CV-550 POWER SUPPLY. Not sure what you mean by exact reference of RAM but this is my RAM 32GB Corsair VENGEANCE DDR4 2400MHz (2 x 16GB)
 

egda23

Upstanding
Jun 14, 2020
428
76
290
15
Not sure what the update was for it was one of those update and shut down ones. I'm on Windows 10. My BIOS is American Megatrends Inc version 3.1. It's 2 X 16GB making 32GB. PSU is a CORSAIR 550W CV SERIES™ CV-550 POWER SUPPLY. Not sure what you mean by exact reference of RAM but this is my RAM 32GB Corsair VENGEANCE DDR4 2400MHz (2 x 16GB)
In which RAM socket do you install your RAM sticks ? Do you refer to page 1-10 of your manual ?
 
Aug 15, 2020
6
0
10
0
In which RAM socket do you install your RAM sticks ? Do you refer to page 1-10 of your manual ?
Yes I've done 1-3 and 2-4. It was working fine previously with slots 1-3 but like i said once i went to shut down my PC it done the update and when I turned it back on it didn't post
 

egda23

Upstanding
Jun 14, 2020
428
76
290
15
The SPD is blanked out but that's what's in my Memory. Thanks for your help so far though, you're being really helpful.

View: https://imgur.com/VRGcOsN
Something is still not right, it should indicate Dual channel and not Single. Are you sure the sticks are in the A2 B2 sockets per your manual ? These are the 2nd and 4 th socket when you start counting from the CPU.
By the way did your RAM come as a kit of 2, or are they 2 separate singles ?
 
Last edited:
Aug 15, 2020
6
0
10
0
Something is still not right, it should indicate Dual channel and not Single. Are you sure the sticks are in the A2 B2 sockets per your manual ? These are the 2nd and 4 th socket when you start counting from the CPU.
By the way did your RAM come as a kit of 2, or are they 2 separate singles ?
The Dimms are definitely seated properly and they are on slots 2 and 4. They are a kit as well. In terms of SPD I meant the slot that's not being recognised (slot 2) is blanked number 4 does show the data View: https://imgur.com/gyNdT1q
 

ASK THE COMMUNITY