[SOLVED] NVMe SSD Not Properly Registering

May 6, 2021
2
0
10
0
Hey guys,

I recently got a Kingston 1TB "A2000" M.2 NVMe SSD for my birthday, and installed in on my desktop Windows 10 computer (I already have one 500GB NVME SSD installed as the boot device).
I tried to format it and make it register as an actual disk by using Disk Management, but it does not show up.



My first thought was that I either somehow managed to install it wrongly or that it was dead out of the box, however:
When I go to the Device Manager application, it shows up under "Disk Drives". It does not display any information on it (it says "Volume information for this disk cannot be found."), but it shows up.

I tried to open CrystalDiskInfo, and while a lot of the info it usually displays is missing for that one drive, it shows up and can even tell the amount of hours it has been on.



Is there a way in which I can format the disk to make it show up and behave like my other one? I am far from an expert and it seems like I overestimated my DIY skills when wishing this for my birthday... Any help will be greatly appreciated!
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Make and model of your motherboard and the BIOS version that you're working with? What version of Windows 10 are you working with? Using Kingston's utility, might want to see if the SSD's need a firmware update.
 
Reactions: ButtonForest
May 6, 2021
2
0
10
0
Thanks for the very quick answers guys! The problem is already fixed and my fears of having to return the SSD are long gone. Have nice days :)
 

ASK THE COMMUNITY

TRENDING THREADS