• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question Onboard LAN adapter is bad or something else?

supo

Honorable
Sep 25, 2014
22
0
10,520
1
Hi, internet was working fine until a few months ago when I started to have problems. I'm trying to troubleshoot it and find the root of the issue.. So basically what happens is that after 1-2 days my internet connection becomes very unstable, getting messages like "Resolving host..." on google chrome, websites opening very slowly or not at all, internet connection becomes very bad on every device etc.

My setup is like this:

I have a ISP router/modem that every device at home is connected to, I have also an unmanaged switch connected to the modem because of more ports obviously which is working without issues for years.. My connected wired devices are: 1 PC (connected directly to the modem), 4 consoles, 2 android tv boxes, then rest of the stuff are WIFI connected like cell phones etc.

Everytime my internet connection goes bad, I tried to unplug the ethernet plug of every device one by one to see if there is a problem with a device that's making the network go bad. So what I found out in the end is that internet connection (on every device) works good again if I unplug the ethernet cable from the back of the modem that goes to my PC and plug it back in OR if I just restart my modem.

So I have tried several things, like changing my modem with another one (3 times) giving my PC a static DHCP address, making the lease times longer, trying public DNS servers, changing ethernet cable with a brand new one, updating my network adapter driver etc. but no matter what I try it keeps happening.

Also when the problem happens and I try to ping a website from the command prompt on my PC I get packet losses or the ping does't work at all. But everything (and every devices internet connection) works magically again if I just unplug the PC's ethernet cable and plug it back again, it saves me time from restarting the modem also.

So what can be the problem? Obviously the PC is the culprit as far as I can but everything was working fine for years. Should also mention that this started happening actually when the ISP decided to "upgrade" the lines in the neighborhood, giving out newer modems to everyone and changing the wall sockets in the apartments.. When contacted about the issue however, the ISP says everything looks good on their end, signal is fine bla bla.

I really need help, sorry for long post.
 
Thank you for the great information. You've done a good job of narrowing it down, so let's continue with that.

Disconnect your ethernet cable from your PC and any wireless--basically disconnect the whole system from the lan for 3 days. I know it will suck, but this will definitively prove it it only your system somehow messing with the network and/or newer isp modem/router combo. If the problem comes back, it's not your system and we need to try a completely different approach.

One we definitively know it's your system, we can try connecting wifi only. Again I know it will probably suck, but if the problem returns it is something on your system doing this. We can further confirm this by booting a linux live cd and connecting via wifi to see if the problem is eliminated. If so, we found the root cause--something on your system hooked into windows.

If the problem does not return, we know it is something with your wired ethernet controller and not the windows network stack in general. We can again boot up a linux live cd and connect your ethernet and see if the problem occurs again. If it does not, it is a windows driver issue with your particular wired ethernet.

If the problem returns, it is something in the network hardware--potentially the cabling or even the port on the switch. Some switches also have oddball incompatibilities that can't be resolved. But if it's something like that, it's easily solved with a different pcie or usb nic or a different cable.

Hope this helps!
 

ASK THE COMMUNITY

TRENDING THREADS