P5Q Pro LED blinking


Jan 14, 2012
my computer is 3years old with Asus P5Q Pro motherboard and worked great until now.
One of my memory sticks had an error and so i've wanted to remove it.

after opening the case and removing two memory sticks i've tried to start the computer.
all i've got is a flashing led on the motherboard, and nothing happens when i press the power on button.

ive tried to put the sticks back but still nothing.
also tried remove all rams, disconnect the HD's, but still notihng.
all i get is a flashing LED.

Can anyone help please?
Thank you
Try resetting the bios with the system unplugged. Remove the round motherboard battery for one minute, and reinstall. You do this by using a small flathead screwdriver and pressing on the tang that holds it in place until it pops up enough to remove it. Then slide the battery under the tang and press back in. Use an esd strap while handling the board/ram/cpu to prevent static discharge damage to the components. They cost about $1. Then install only one ram stick in dimm slot one, and see if you can get it to post. You probably just have one loose that's not quite seated all the way into the slot.