Question PC Blue Screening When Connecting to wifi

May 1, 2020
9
1
15
0
My PC has only been doing this since I moved house, it starts up fine and whatever but when I try to connect to the wifi it blue screens with DPC_Watchdog_Violation. Now I've gone and bought a new wifi dongle (D-Link AC1900) as I thought it was that but it has only made it worse. I played all night last night without any issues but today I can't even watch a youtube video without it crashing 5 minutes in. The computer runs fine if I don't touch the internet bar in the taskbar but as soon as I do <Mod Edit> breaks loose. The internet is working fine on all my other devices so I have no idea what it could be. If worst comes to worst I can full reset my computer but I'd rather not.

I can answer any questions you have if it's going to help, thanks.
 
Last edited by a moderator:
My PC has only been doing this since I moved house, it starts up fine and whatever but when I try to connect to the wifi it blue screens with DPC_Watchdog_Violation. Now I've gone and bought a new wifi dongle (D-Link AC1900) as I thought it was that but it has only made it worse. I played all night last night without any issues but today I can't even watch a youtube video without it crashing 5 minutes in. The computer runs fine if I don't touch the internet bar in the taskbar but as soon as I do <Mod Edit> breaks loose. The internet is working fine on all my other devices so I have no idea what it could be. If worst comes to worst I can full reset my computer but I'd rather not.

I can answer any questions you have if it's going to help, thanks.
run cmd as admin and run sfc /scannow
 
Reactions: Xavierol1

Abhinav2005

Notable
Jan 1, 2020
449
104
990
25
My PC has only been doing this since I moved house, it starts up fine and whatever but when I try to connect to the wifi it blue screens with DPC_Watchdog_Violation. Now I've gone and bought a new wifi dongle (D-Link AC1900) as I thought it was that but it has only made it worse. I played all night last night without any issues but today I can't even watch a youtube video without it crashing 5 minutes in. The computer runs fine if I don't touch the internet bar in the taskbar but as soon as I do <Mod Edit> breaks loose. The internet is working fine on all my other devices so I have no idea what it could be. If worst comes to worst I can full reset my computer but I'd rather not.

I can answer any questions you have if it's going to help, thanks.
this error generally occurs due to old or wrong driver. So try updating your wifi drivers or try it reinstall.
 

ASK THE COMMUNITY

TRENDING THREADS