PC failing to boot past start up screen

Nov 12, 2018
Hello there,
My housemates PC has suddenly stopped working. It's been working fine up until last night, then this morning it's not working. I built the PC It was built around 2015(I also built my own in 2015 and zero issues so far, amateur stuff).
Motherboard: ASRock z97 Extreme 3
PSU: Silverstone 650w
Processor: Intel core i7-4790k
Ram: 16gb corsair vengeance (4x4gb)
SSD: Samsung Evo 850 250gb
HDD: 2TB WB Black
OS: windows 7 64bit

When you turn the PC on it shows up the ASrock logo screen with the "F2 to enter bios/uefi" thingy information, the after that it just goes black. I can still get into the ASRock uefi (admittedly I have little knowledge on how to use it) That's about all the functionality the PC has right now.
The fans appear to be on and the power light is on on the case. The red loading light on the case seems to be always lit up too while the black screen is up.
Because I don't really know how to deal with this problem I've tried a couple of thing. I thought it might have been some of the hardware so I took the GPU out and plugged screen into the mobo slot, but this had no effect. I took out the ram and replaced them one each at a time to see if any of them was faulty or if that would do anything, but again no effect. I took out the 2TB drive (it's purely storage) to see if there was any conflict or interference. I'm at a complete loss.
Edit: Sometimes it fails to power up, it lights up, goes off, then ramps up after. This has happened before apparently.
Any help would be greatly appreciated.