Question PC Shutting down immediately after turning on

Oct 18, 2020
3
0
10
0
I built a new PC couple months ago, it had a Corsair TX650M PSU but after a few weeks its capacitors popped and I had to RMA it. The new one arrived a few days ago, first couple of days it worked fine, but today when I turned it on it shut down itself in a couple of seconds. I turned it on again and it worked fine, after doing my work I shut down the PC again. Then when I turned on the PC again couple hours later, it shut down again in a second.



What is causing the problem? Is this PSU also faulty?

Parts list - https://pcpartpicker.com/list/7HkKjp

Also, this time I am also using a UPS rated for 1100VA/660W where I have plugged in the PC, the monitor and the wifi router. Could this have something to do with the issue?
 

Vic 40

Titan
Ambassador
Not really into ups so can only say try powering the pc directly to the wall. See if it makes a difference.

Other thing might try is using both pcie cables (one connector each=first) instead of one (two connectors)
 
Oct 18, 2020
3
0
10
0
Not really into ups so can only say try powering the pc directly to the wall. See if it makes a difference.

Other thing might try is using both pcie cables (one connector each=first) instead of one (two connectors)
I'll try the first thing. But I don't understand the second part. What do you mean using both pcie cables
 
Oct 18, 2020
3
0
10
0
The TXM 650watt comes with four pcie connectors on two cables. You probably use one cable and the two connectors it supplies. Test by using both cables.
Oh, yeah I am already using two different cables for the GPU, same with SATA cables, I am using two different cables for HDD and the AIO.
I will try and start it while plugged into the wall to see what happens when I get back home from work.
Could it be something to do with the fact that I have enabled PBO and maybe thats why cpu is sucking more power than what the UPS can supply?
 

ASK THE COMMUNITY

TRENDING THREADS