Question PC Slow after upgrading components

Jun 20, 2019
38
2
45
1
Hi, today I upgraded my CPU, and changed my MoBo and RAM. After upgrading it, the PC felt way slower than before. What can cause the lag? Is it possibly that I don't have an SSD?

Specs:
GPU: Geforce 1060 6GB
CPU: AMD Ryzen 7 2700X (before was Athlon X4 840)
MoBo: Gigabyte B450 AORUS ELITE (rev. 1.0) (previous was Gigabyte GA-F2A68HM-S1)
RAM: G.SKILL 16GB Aegis DDR4 3200MHz (previous was Crucial 16GB DDR3 1600MHz)
PSU: RX-550PA
HDD: Toshiba P300 1TB

My only guess is that it's only the HDD that's slow, and I don't have an SSD?

Thanks
 
Last edited:

kurdtnz

Great
Feb 24, 2020
183
14
95
1
I cant comment on your other components but having recently done it myself, upgrading to a ssd will significantly speed up and improve your system.(especially if you use it to boot from.)
 

Djoza

Prominent
Apr 5, 2020
792
106
590
18
Hi, today I upgraded my CPU, and changed my MoBo and RAM. After upgrading it, the PC felt way slower than before. What can cause the lag? Is it possibly that I don't have an SSD?

Specs:
GPU: Geforce 1060 6GB
CPU: AMD Ryzen 7 2700X (before was Athlon X4 840)
MoBo: Gigabyte B450 AORUS ELITE (rev. 1.0) (previous was Gigabyte GA-F2A68HM-S1)
RAM: G.SKILL 16GB Aegis DDR4 3200MHz (previous was Crucial 16GB DDR3 1600MHz)
PSU: RX-550PA
HDD: Toshiba P300 1TB

My only guess is that it's only the HDD that's slow, and I don't have an SSD?

Thanks
remove any programs ad files u dont use.Do a disk cleanup and defragmentation.Keep me updated me with the sutiation
 
Jun 20, 2019
38
2
45
1
Hi, I upgraded my PC like 3-4 days ago. Everything was fine, but I noticed one thing: When playing games, after 5-60 minutes of playing it would say "Application Crash Detected" and there's a problem with the GPU.

Today, I booted my PC, and saw that it would instantly crash, and Microsoft Edge get's blacked out every 5-10 minutes so I have to kill it in Task Manager and start it again.
Is that because of my GPU, or is it some other component?
Thanks.
 

Nigel Spike

Reputable
Jan 9, 2016
789
36
5,440
180
You may want to include your specs and PSU.
Your question for a random GPU running on a random system, powered by a random PSU, may result in a random reply.
Example: Yes, your problem can be a result of your GPU or some other component.
 
Jun 20, 2019
38
2
45
1
You may want to include your specs and PSU.
Your question for a random GPU running on a random system, powered by a random PSU, may result in a random reply.
Example: Yes, your problem can be a result of your GPU or some other component.
Hi, the specs are on my signature.

CPU: AMD Ryzen 7 2700x
GPU: Nvidia GeForce GTX 1060 6GB
RAM: G.Skill 16GB Aegis DDR4 3200 MHz
PSU: RX-550PA 550W
HDD: Toshiba P300 1TB
SSD: None
 
Jun 20, 2019
38
2
45
1
Hi, I have recently upgraded my CPU, but now when I play games, the GPU 3D usage is ~10-15%.

After playing 20-30 minutes, the game crashes and the 3D GPU usage spikes to 100%, and goes back down to 0.

It's really annoying.

Please help, thank you!
 

ASK THE COMMUNITY

TRENDING THREADS