Posts In Thread Are Always White

slvr_phoenix

Splendid
Dec 31, 2007
6,223
0
25,780
0
Okay, this may have been going on for a while. I thought it was my imagination at first, but I've definately reproduced it a number of times now.

When you click on a thread and see all of the pretty little posties in a row, they're all white, regardless of if you've read them before or not yet.

This makes it kind of hard to determine where you should start reading from.

The funny thing is, that the thread views and such steps back are all right. It's only when in a thread looking at the individual posts that it's wrong. So you know when a thread has new posts, but then it can be a dickens to figure out which ones are the new ones and which are old.
 

steve_sa

Distinguished
Nov 6, 2005
662
0
18,980
0
When looking at a thread, the unread posts are orange, and the read posts are white. At least, that is how it works for me....

slvr, you are a s/w engineer, so if the problem persists, figure out how I can replicate it :wink:
 

slvr_phoenix

Splendid
Dec 31, 2007
6,223
0
25,780
0
All I can say is the way that I can replicate it. :lol:

New threads don't seem to be affected. They work peachy keen.

But existing threads that aquire new posts get their thread icon oranged, but the posts themselves in the thread remain white. Now that I look for it, it's actually incredibly consistent. For that matter, are the last post icons meant to be orange? Because they're all white too, regardless of read state.

And you're right. As a software enginner I should give you more info to go on. Shame on me.

My browser is Firefox 1.5. OS is WinXP Pro, SPed and updated up the arse. And I'm currently wearing my contact lenses, which maybe is why it took so long to notice. I don't focus as hard when I wear them because they dry out quickly if I stare too intently. (Which is why sometimes I were glasses instead.)

Though I also just tested it on IE6 and it's doing exactly the same thing. So unless there's something weird in my profile or aliens are intercepting my communique, I don't know how you're not seeing it. Do you use Opera? (Or maybe Lynx. :lol:)

This should also serve as a test of what happens if I log in with one browser and then in the middle of writing a post log in with a different browser and surf to another section. :eek:
 

slvr_phoenix

Splendid
Dec 31, 2007
6,223
0
25,780
0
Okay, the submit with seperate browser interference worked fine. That's cool. It doesn't invalidate my previous logon by logging on elsewhere. :D

And I'll see about getting screen shots for you.
 

slvr_phoenix

Splendid
Dec 31, 2007
6,223
0
25,780
0
Screen shots are on their way.

Oh, also I've noticed an increasing number of threads get a 'last post' icon appended to the front of the thread title in the section view. What's up with that? Is that a bug or a feature? :lol:
 

fishmahn

Distinguished
Jul 6, 2004
3,197
0
20,780
0
I've seen the same thing, but it seemed inconsistant. I just figured out what's happening. (at least in my case).

I ran through the forums this AM, but didn't visit the Other. I went to the Other after lunch, and found threads like Silver is reporting.

Any all new thread where nothing had been read is fine.

Any thread who's last post is before my last visit time (shown on the category page) shows all the posts as read even though the thread list shows it as having unread posts.

Any thread with posts newer than my last visit time shows the posts prior to last visit as read (even if I hadn't viewed all of them yet) while the post(s) after my last visit are unread.

Hope it helps in debugging.

Mike.
 

slvr_phoenix

Splendid
Dec 31, 2007
6,223
0
25,780
0
Duh! I'm so smart. (Not.)

I just realized it's a bug. Not only is it a bug, it's related. Der to me.

It looks like the last post's colored icon is actually being set in front of the thread name column instead of the last thread column. :lol: So at least I've figured out that the last thread icon really is meant to be orange. Maybe the posts don't get their icons right because it's trying to change the icon to the orange one in the wrong column too?
 

slvr_phoenix

Splendid
Dec 31, 2007
6,223
0
25,780
0
Okay, here's a fresh new description of what I'm observing with all of the pieces of the puzzle put in.

In the section view the orange/white icons are working just fine.

In the thread view, the leftmost orange/white icon for the thread itself is working fine. But the rightmost 'last post' icon isn't.

The rightmost 'last post' icon is always white. Further, if there is a new last post, an orange arrow icon appears in the 'Topics' column, not the 'Last Post' column. This in fact even has a link, but if you click on this erronious icon/link in the 'Topics' column, it always says:
Information
No new posts since your last visit
So it looks something like this:
[code:1:9ec4fb8aa7]------------------------------------------------------------------------
| | Topics | Replies | Author | Last Post |
|-----|-----------------|-----------|--------------|-------------------|
|([o])| ->[o] Welcome! | 1 | bug-o-matic | Mr.Respondo ->[w] |[/code:1:9ec4fb8aa7]

* Note tha the [o] is an orange page graphic, and the [w] is a white page graphic.

If I click on the link after Mr.Respondo, it takes me to the thread, but all posts are white.

If I click on the link (that shouldn't exist) before Welcome! it says no new posts.

And further, as stated, whenever I look into any thread to the lists of posts, every post icon is always white. They're never orange, even when they're new. Unless every single post in the thread is new, in which case they're all orange. That's the only time it seems to work right.

And this occurs under both FF1.5 and IE6, so I doubt that it's browser related.

And now that I'm paying attention, I can say that it happens each and every time. It's very consistant.
 

steve_sa

Distinguished
Nov 6, 2005
662
0
18,980
0
Ok, I looked into this, and here are the observations:

1. The "lost post" icon is always white. We don't change that color. It is just an icon with no status.

2. If you look at a thread, and half of the posts are white even though you did not read the thread, that is due to you having done a "marked this forum read" [steve: edited this], which causes posts before mark time to be white.

3. View posts since last visit uses the "real" last visit, i.e. last time you were on. The red/white logic goes back 7 days (always) so that people don't miss posts (by request). So they are not the same animals.

After reading the above considerations, can you restate the problems that remain (and perhaps tell me how to remove the confusion regarding 'posts since last visit' without removing the functionality).
 

russell

Distinguished
Apr 1, 2004
3,085
0
20,780
0
3. View posts since last visit uses the "real" last visit, i.e. last time you were on.
How does the server decide that I have left?
Do I have to log out? If so I can't just set a link straight into a particular section.
Does the server sense that I have left if I close the browser page?

I have noticed that the "your last visit was" thingy is seldom right, this could be what is screwing up the read/un-read post marker!
 

steve_sa

Distinguished
Nov 6, 2005
662
0
18,980
0
russel, there is a one hour session... if you are not active for one hour (hitting the server) it will close you, or you logout. Either way.

Closing browser has no effect on this.

Yes, 'last visit' and read/unread are different animals. It can get confusing as typically show posts since last visit shows less orange entries than are lit.
 

russell

Distinguished
Apr 1, 2004
3,085
0
20,780
0
OK so lets say @12:00 I leave the forum but I don't log out.
Now let's say there were perhaps ten new posts between 12:00 when I left and 1:00 when the server closes me. What happens to these ten posts? Will they be marked as unread when I return? Or will they be marked as read? remember you have thUnder the at one hour time constraint.
 

steve_sa

Distinguished
Nov 6, 2005
662
0
18,980
0
They will be orange. In fact the server ignores your last visit, and marks anything new in the past 7 days as orange. This is done since people were complaining about leaving their pc/logging out, and missing out on new posts.

The "real" last visit (12:00 PM) comes into effect only for doing 'show posts since last visit' query.
 

slvr_phoenix

Splendid
Dec 31, 2007
6,223
0
25,780
0
1. The "lost post" icon is always white. We don't change that color. It is just an icon with no status.
Are you sure about that? I don't think so. If that's true then why is a new erronious (and orange) "last post" icon showing up in the topic column where it doesn't belong? It looks to me like you are trying to change the "last post" icon to orange, but you're doing it in the wrong place.

2. If you look at a thread, and half of the posts are white even though you did not read the thread, that is due to you having done a "marked this forum read" [steve: edited this], which causes posts before mark time to be white.
And I'm saying that they've been marked as white when I'm not using any "mark as read" features. Heck, they were all marked as white, no matter what, as my screen shot showed. There were brand spanking new posts being marked as white.

However, funnier still, is that since my last post this is no longer happening. Suddenly this bug looks fixed. Obviously you must have found and fixed something that related to this bug even though you so far haven't accepted that it is a bug and seemed to be oblivious to it. :lol:

3. View posts since last visit uses the "real" last visit, i.e. last time you were on. The red/white logic goes back 7 days (always) so that people don't miss posts (by request). So they are not the same animals.
I've never even used this feature, so this has no meaning to me. In fact, I don't think anyone has mentioned this feature in this thread... :?

After reading the above considerations, can you restate the problems that remain (and perhaps tell me how to remove the confusion regarding 'posts since last visit' without removing the functionality).
I'm not sure how I can make it more plain. :? No one has even mentioned the 'posts since last visit' feature and yet you're going on about it. The screen shots that I sent by email said it all. My last post using ASCII art said it almost as clearly. But here it goes ... again.

1) The posts in a thread were being marked white when they should have been orange. Without using any 'mark all' features. You could look at a thread and see that it had an orange indicator. If you clicked on that thread, all posts were white, including the new posts that caused the orange indicator on the thread. The only time when this was not true was when every post was new, in which case they were all orange. But so long as the first post was white, they were all white.

This bug however seems to have been fixed very recently. Even though you don't seem to understand what's going on, you must have found something, because today this bug is no longer happening.

But if you didn't change anything there, then I have to wonder if there's still a lingering bug waiting to pop up again at a later date.

2) The shortcut to the last post in a thread is always white graphic. This itself may not be a bug, but it looks like one in light of the following number 3.

3) A new second last post in a thread shortcut is being placed in the left side of the Topic column. (Instead of being in the Last Post column where it belongs.) This new icon is orange, like it should be. This new icon also has a link, but that link doesn't work. This new icon only appears if the thread has a new post. If the thread's posts are all read, this shortcut does not appear.

So it looks very much like you are trying to overwrite a default white shortcut to the last post in a thread with an orange one if that last post is new, but you've just royally screwed it up.
 

russell

Distinguished
Apr 1, 2004
3,085
0
20,780
0
You lost me with the last (number 3) remark. I know you are talking to Steve but am I missing some feature that I don't know about? What do you mean "last post in a thread shortcut "? Maybe this is something that shows up with the collapsed viewing option active.

Just curious.
Russell
 

slvr_phoenix

Splendid
Dec 31, 2007
6,223
0
25,780
0
In the list of Topics (threads) there are four columns: Topics, Replies, Author, and Last Post. The last post column contains the date, time, and name of the last person to post in that thread. Then after that is an icon looking like an arrow pointing to a page. Click that icon and it'll open the thread, taking you to its last post. It's a (somewhat) convenient shortcut.
 

slvr_phoenix

Splendid
Dec 31, 2007
6,223
0
25,780
0
I totally agree. I've suggested the same myself in a number of places.

Maybe if we keep bringing it up

again

and again

and again

and again

someone will finally bother putting it in. :mrgreen:
 

dhlucke

Polypheme
Scuba Steve! I have a request. It's kinda a bug.

If there are multiple pages in a thread with new posts then if you click ALL you can see which posts are new by the orange icon. However if you click on one of the numbers you only see the new ones in that number. Once you go to the next number it doesn't show the orange icon next to new posts that you haven't read.
 

steve_sa

Distinguished
Nov 6, 2005
662
0
18,980
0
Scuba Steve! I have a request. It's kinda a bug.

If there are multiple pages in a thread with new posts then if you click ALL you can see which posts are new by the orange icon. However if you click on one of the numbers you only see the new ones in that number. Once you go to the next number it doesn't show the orange icon next to new posts that you haven't read.
I fixed this one. If you go to a page, and now you go to the next page, the orange is still there.

I am thinking all the other problems in this thread related to the same thing :?
 

ASK THE COMMUNITY