Question Power is there but PC won't boot

Feb 22, 2019
3
0
10
0
While I was using my (almost new i.e. 4 months-old) build the PC simply shut off mid use and it refuses to boot back up again.

I have checked the kettle cord, made sure all components are seated correctly and tried a different power outlet but still it won't boot up.

The strange thing is that there is still power flowing - my USB keyboard lights up and I can charge my phone through the USB also.

When I take out and put the kettle cable back in and turn the PSU on and off the PC makes a clicking noise that it normally makes when booting up but doesn't actually boot. After trying again there is no more encouraging noise at all.

I don't really have the expertise to mess about with the motherboard.

PSU is a Corsair CX-M 650W.

Any thoughts on what else to try before taking it to someone to look at?
 

nick_v15

Prominent
BANNED
Jan 7, 2018
365
18
795
2
Unplug it from power.Unplug all the drives except the one with the OS.Keep pressing the power button for 10 secs.Replug power (with only the OS drive connected and gpu).Tell me if you can get to bios.
 
Feb 22, 2019
3
0
10
0
I only have the one drive, it's a mini PC.

Tried to hold down power button with PSU off for the 10 secs and then turned PSU back on while still holding the button. Got that lovely clicking noise but still not to bios.
 

nick_v15

Prominent
BANNED
Jan 7, 2018
365
18
795
2
I have 2 thoughts...1.Either something is fried.2.Open the pc and clean it with air duster.Something is keeping it off to protect itself from frying.
 
Feb 22, 2019
3
0
10
0
It's only four and a half months old so I seriously hope it isn't something fried and doubt it's to do with dust since it has many filters.

Have taken it to your Hardware Aficionado Brothers&Sisters in Arms since I don't know anyone here with a spare PSU to try. Will report back with findings.

Thanks for your help nonetheless.
 

ASK THE COMMUNITY

TRENDING THREADS