[SOLVED] Problem turning PC on.

Jul 14, 2020
3
0
20
1
Hello there. I'm new here, so, thanks in advance for any help you can give me.

I am having a small problem but that bugs me quite a bit. If I completely power off the computer, when I am trying to turn it on, it won't turn on the first time I press the power button, instead the front Led panel of the rig witll turn on for a second and then turn off immediately, just like when you unplug the PC and press the power button to discharge the remaining electricity. Then if I press the button again it will turn on normally. And then if I put the PC on rest mode, if I try to wake it up right away it will, but after a couple of minutes or maybe an hour or so, if I try to wake it by clicking on the mouse or pressing a key, the same thing will happen, the front LED will flash and the computer won't wake. I have to press the power button after that to wake it properly. It's the only problem I'm having but it seems oddly specific.

I don't know if my specs will help with this but here they are anyway:

AMD Ryzen 7 3700X 8-Core 3.59 GHz,
32 GB RAM
Cougar CMX 850 power supply
Cooler Master Masterliquid Lite 240
GPU NVidia RTX 2080 SUPER
ASRock B450 Steel Legend Motherboard

All of it inside a Cougar case.

Thanks!
 
Last edited:
Jul 14, 2020
3
0
20
1
Ok, since I ended up figuring out myself I thought about sharing it here, maybe it'll help somebody.

In this new rig whenever I would turn off the PC the inner lights would still be on (RGBs on the RAM, etc.). So, when I pressed the power button it would first flash the fron Led, and then turn it off and all the inner lights would turn off too. It is as if the first press of the button would discharge the remaining power that was keeping the lights on and then the second press would turn on the computer. Also, if I turned off the switch behind the computer and the lights would go off, then when pressing the power button it would turn on normally, so I assumed it was related to that. I went into power options in the Bios and enabled the option of deep sleep, so when I turn off the computer now all lights inside the rig go off, and now when I press the power button it would turn the PC on immediately, no more double pressing. I have no idea why the lights would cause such behavior but.. it was that.

Thanks for the interest.
 
Jul 14, 2020
3
0
20
1
No. Still happens. Yours seems more random. My problem is each time trying to turn it on, it always turn on with the second press, never with the first. But so far nothing. Because I tried some solutions I found about changing Windows to not allow fast boot and such, but nothing seems to work.
 
Jul 14, 2020
3
0
20
1
Ok, since I ended up figuring out myself I thought about sharing it here, maybe it'll help somebody.

In this new rig whenever I would turn off the PC the inner lights would still be on (RGBs on the RAM, etc.). So, when I pressed the power button it would first flash the fron Led, and then turn it off and all the inner lights would turn off too. It is as if the first press of the button would discharge the remaining power that was keeping the lights on and then the second press would turn on the computer. Also, if I turned off the switch behind the computer and the lights would go off, then when pressing the power button it would turn on normally, so I assumed it was related to that. I went into power options in the Bios and enabled the option of deep sleep, so when I turn off the computer now all lights inside the rig go off, and now when I press the power button it would turn the PC on immediately, no more double pressing. I have no idea why the lights would cause such behavior but.. it was that.

Thanks for the interest.
 

ASK THE COMMUNITY

TRENDING THREADS