Question Problem with flickering (triple monitor setup, one with 144hz)

ropefly

Reputable
Jul 17, 2014
21
0
4,510
0
I recently purchased a 144hz 1080p display and my god what a difference compared to my old 60hz TN monitor but aside of that.

Once my 144 is enabled, my other 2 monitors (both on 60hz) start flickering like once every 15 seconds.(at the same time).
If I disable my 144hz back to 60 it's gone but If I'm playing a game full screen on 144 the flickering is also gone.

It's only the 2x 60hz that flicker, never the 144hz.

Setup is a rtx 2070 with a ryzen 7 if that matters.
144 is connected with display port and the other 2 with hdmi(one with a hdmi to display connector because I only have 1 hdmi + 3x display on my GPU)

Off course I can always just simply disable 144 when not gaming but I assume there's probably a solution with settings or something that makes it flicker.


Ps: the flickering is a lot but not always, I think it usually happens after I played some games.
If I just boot up my pc there's no flickering(yet) but once it starts it won't stop unless I boot up a game and focus on the 144hz or until I disable 144hz

Edit: It's an msi mag241c display
 

ropefly

Reputable
Jul 17, 2014
21
0
4,510
0
This is normal when there are several monitors running on different refresh rates. Never seen a fix for this, you can check with the video card vendor support and see if they suggest anything.
oh for real? lol guess manual swapping to 60/144 is the only solution then. Thanks for the info
 

ASK THE COMMUNITY