[SOLVED] Random fps drops when playing, from 100+ fps to 15

Aug 27, 2021
4
0
20
1
My specs:
Ryzen 5 3600 (Gammaxx GTE V2 Cooler)
B450M Plus-Gaming TUF
RX 5500 XT (4GB)
HyperX 2x8GB 2666mhz
Cougar GEX 650w gold

So, I can run games like MHW on high and get around 60 fps. I can run DRG on ultra and get 100+ FPS. Even Apex on mostly low for performance and get 180+ fps. The only problem is after a bit it suddenly drops down to 15 fps for a solid 5-10 seconds, it does this at random too and usually with nothing too graphically intensive on screen. I've checked temperatures on my CPU and GPU using HWinfo and it says my GPU peaks at 82-84c and average temps of 74c, CPU peaks at 74c and averages on 63c. By checking it out using HWinfo it doesn't seem like it's thermal throttling, could HWinfo be giving false temps? I also ran MSI afterburner while playing Deep Rock Galactic and it runs normally, 100+ fps and all that, then a bit later my GPU clock speed lowers from its normal clock speed to 296mhz and CPU dropping to like 11% usage. I've searched reddit, forums and the like and none of the things they tried fixed mine. What is this? What can I do to stop this?? Please help, I just want to game :(
 
Aug 27, 2021
4
0
20
1
what is the ram and ssd usage during the drop?
I just read another forum talking about GPU fan curves, I put a fan curve on my gpu. Turns out it really was overheating but the gpu was preventing high temps by lowering the clock speed so it displays low-ish temps on HWinfo. I just set fan speed to 100% whenever it reaches relatively high temps and it didn't FPS drop anymore.
 
Aug 27, 2021
4
0
20
1
what is the ram and ssd usage during the drop?
I just read another forum talking about GPU fan curves, I put a fan curve on my gpu. Turns out it really was overheating but the gpu was preventing high temps by lowering the clock speed so it displays low-ish temps on HWinfo. I just set fan speed to 100% whenever it reaches relatively high temps and it didn't FPS drop anymore.
 

ASK THE COMMUNITY